Virtualization Plugins

Expand all | Collapse all

SDK - Only Lua toolkits are supported.

Jump to Best Answer
  • 1.  SDK - Only Lua toolkits are supported.

    Posted 05-13-2019 08:44:00 AM

    Hello,
    I installed on the SDK server, trying to load artifact.json I have the following error:
    The uploaded toolkit "first_plugin" uses the language "Python 2.7". Only Lua toolkits are supported.
    It appears that Engine does not support the Python language but only LUA.
    How can I solve the problem?

    Thank you,
    Eugenio


    #VirtualizationPlugins


  • 2.  RE: SDK - Only Lua toolkits are supported.
    Best Answer

    Posted 05-13-2019 12:04:00 PM
    Hello Eugenio,
                            You need to enable Python Flag in Delphix Engine before this step, by following below instructions-

    Enable the Delphix Engine Feature Flag
    Login to the Delphix Engine CLI as the sysadmin user:

    $ ssh sysadmin@<delphix-engine-hostname>
    > system
    > enableFeatureFlag
    > set name=PYTHON_TOOLKITS
    > ls
    Properties
    type: FeatureFlagParameters
    name: PYTHON_TOOLKITS (*)
    > commit
    Feature flag "PYTHON_TOOLKITS" enabled. If using the CLI, log out and log back in to use the feature. 
    Warning: This feature is only supported for specific configurations. If you do not have explicit permission from your account representative to use this feature, disable it and contact them.


  • 3.  RE: SDK - Only Lua toolkits are supported.

    Posted 05-13-2019 12:15:00 PM

    Thanks,
    now works.

    Thanks,
    Eugenio


  • 4.  RE: SDK - Only Lua toolkits are supported.

    Posted 05-13-2019 01:32:00 PM
    Eugenio - if you have any further questions, feel free to post in the Virtualization">https://community.delphix.com/delphix/categories/delphix_virtualization_plugins">Virtualization Plugins Category/Forum. A team of engineers is constantly monitoring questions posted in that category.