Virtualization Plugins

Expand all | Collapse all

Error DB_DELETE SDK

Jump to Best Answer
  • 1.  Error DB_DELETE SDK

    Posted 09-12-2019 03:02:00 AM
    Hi all,
    we're trying to upload the a plugin developed with Delphix SDK, but the upload results with error

    Than, we have tried to delete the dsource, but the deletion results in this error.

    Even performing a refresh of the Environment results in this error

    The folder with the plugin inside no longer exists, it has been deleted for error



    How can we delete the dsource?

    Thank you,
    Eugenio





    ------------------------------
    Eugenio -
    Community Member
    Higher Logic Community Members
    ------------------------------


  • 2.  RE: Error DB_DELETE SDK
    Best Answer

    Posted 09-12-2019 02:45:00 PM
    Hi Eugenio,

    The upload failure is known and expected. We do not support plugin upgrades with schema changes at this time, but are actively working on it. In order to upload a new version of the plugin, you need to delete objects that are of the type of the changed schema. (Ex: VDBs need to be deleted if there are virtual source schema changes).

    The delete issue seems to be a problem on the Delphix Engine. I see that you have a support case filed. We will need a support bundle to diagnose the issue. Could you upload a support bundle to the support case? We will follow up through that.

    - Grant

    ------------------------------
    Grant Magdanz
    Senior Member of Technical Staff II
    Delphix
    ------------------------------



  • 3.  RE: Error DB_DELETE SDK

    Posted 09-13-2019 07:06:00 AM
    Hi Grant,
    thanks for the support, I solved the problem by restarting the server where sdk is installed

    Thanks,
    Eugenio Pascuzzi

    ------------------------------
    Eugenio -
    Community Member
    Higher Logic Community Members
    ------------------------------



  • 4.  RE: Error DB_DELETE SDK

    Posted 09-13-2019 09:08:00 AM
    Hi Eugenio,
        Thanks for the update, and glad to hear the issue is resolved.  Could you please provide a bit more information on what was restarted?  Are you saying the Delphix Engine was restarted?  Or was the server that you were uploading the plugin from restarted?  After the restart you were able to delete the source?

       The reason for asking is that typically restarting a server should not be required to resolve an issue and it would be useful for us to know why that resolved the issue.  Any information you can provide would be greatly appreciated, and if you could upload a support bundle to the support case that would be helpful.

    Thanks
    Brian Kobus

    ------------------------------
    Support Org
    Senior Support Engineer
    Delphix
    ------------------------------