Delphix Products

Expand all | Collapse all

Trouble setting up Delphix database user

Jump to Best Answer
  • 1.  Trouble setting up Delphix database user

    Posted 12-02-2015 07:58:00 PM
    Hi,

    I'm trying to setup Landshark as a sandbox using the sample provided on a memory stick in the training summit.  I'm trying to add the built-in Oracle database for my source and connect to it.  In the environments view, I find the proper database.  When trying to authenticate to it given the user/pass combo "delphixdb/delphixdb," I get an error that the user does not exist.

    Upon further probing, I found a createDelphixDBUser.sql script and from the User guide a createDelphixDBUser.sh script. Running the script, I get the following:


    [delphix@delphix-source ~]$ ./createDelphixDBUser.sh

    This script will create the Delphix database user

    Database User will be created in instance <XEXE>
    If you would like to create the DB user in a different Database Instance,
    please enter the desired SID or press <Enter> to proceed.
    XEXE
    select 'Version=' || version from v$instance
    *
    ERROR at line 1:
    ORA-01034: ORACLE not available
    Process ID: 0
    Session ID: 0 Serial number: 0
    Unable to get database version from database instance <XEXE>.


    Is this saying the server is not up?  I'm confused how to resolve this. When doing a lsnrctl, I get the following:

    [delphix@delphix-source scripts]$ lsnrctl status

    LSNRCTL for Linux: Version 11.2.0.2.0 - Production on 02-DEC-2015 14:57:17

    Copyright (c) 1991, 2011, Oracle.  All rights reserved.

    Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
    STATUS of the LISTENER
    ------------------------
    Alias                     LISTENER
    Version                   TNSLSNR for Linux: Version 11.2.0.2.0 - Production
    Start Date                01-DEC-2015 14:15:59
    Uptime                    1 days 0 hr. 41 min. 18 sec
    Trace Level               off
    Security                  ON: Local OS Authentication
    SNMP                      OFF
    Listener Log File         /u01/app/oracle/diag/tnslsnr/delphix-source/listener/alert/log.xml
    Listening Endpoints Summary...
      (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=delphix-source)(PORT=1521)))
    The listener supports no services
    The command completed successfully


    Which shows that its running, correct?  I'm confused as to how to resolve this.  Any help would be appreciated!


    Thanks,
    Scott






  • 2.  RE: Trouble setting up Delphix database user
    Best Answer

    Posted 12-02-2015 08:08:00 PM
    Hey Scott. First, I see that you changed the name of your linux VM. That is going to create some problems. You should change it back to linuxsource and reboot. If you have changed the target, also change that back to linuxtarget, and reboot. Did you follow this quickstart guide? 

    https://docs.delphix.com/display/LS22/Quick+Start+Guide+for+the+Delphix+Landshark+Environment


  • 3.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 05:04:00 PM
    Thanks for the reply Adam.  I had the sysadmin set these up, and we didn't use the quickstart guide.  Should I set the Landshark engine to be DelphixExpress as well?


  • 4.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 05:06:00 PM
    Well, for ease of setup, I would recommend it (thought that is a configurable value). I would recommend going through the quick start, and then once you are comfortable with how everything interconnects and works, you could always try a more customer installation afterwards. 


  • 5.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 08:38:00 PM
    Adam,

    So I set all the hosts to those names, rebooted, and still seeing the same issue.  I tried this:

    [delphix@linuxsource ~]$ sqlplus '/ as sysdba'

    SQL*Plus: Release 11.2.0.2.0 Production on Thu Dec 3 14:28:29 2015

    Copyright (c) 1982, 2011, Oracle.  All rights reserved.

    Connected to an idle instance.

    SQL> select open_mode from v$database;
    select open_mode from v$database
    *
    ERROR at line 1:
    ORA-01034: ORACLE not available
    Process ID: 0
    Session ID: 0 Serial number: 0


    So it still seems that Oracle is not up.  I also tried these two commands and got the following:

    SQL> alter database startup
      2  ;
    alter database startup
    *
    ERROR at line 1:
    ORA-01034: ORACLE not available
    Process ID: 0
    Session ID: 0 Serial number: 0


    SQL> startup
    ORA-00119: invalid specification for system parameter LOCAL_LISTENER
    ORA-00130: invalid listener address '(ADDRESS=(PROTOCOL=TCP)(HOST=linuxsource.delphix.local)(PORT=1521))'

    I consulted a fellow colleague I met at the summit they suggested perhaps reinstalling the OVA as perhaps part of the DB mount point is missing entirely, like maybe some virtual disks did not get mounted.  Checking my config, here is what I see:

    [delphix@linuxsource ~]$ id
    uid=501(delphix) gid=500(oinstall) groups=500(oinstall),4(adm),27(mysql),501(dba),1009(sybase)
    [delphix@linuxsource ~]$ env | grep ORACLE
    ORACLE_SID=XEXE
    ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe
    [delphix@linuxsource ~]$ df -kh
    Filesystem                          Size  Used Avail Use% Mounted on
    /dev/mapper/vg_linuxsource-lv_root  2.2G  1.9G  260M  88% /
    tmpfs                               939M     0  939M   0% /dev/shm
    /dev/sda1                           485M   32M  428M   7% /boot
    /dev/sdb                             30G  2.4G   26G   9% /data




  • 6.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 08:45:00 PM
    ok. So what are the last lines in the log from step 12?



  • 7.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 09:21:00 PM
     Just tried reinstalling the image for source.  Here is the log:

    INFO:2015-12-03 16:51:21:Starting Listener
    INFO:2015-12-03 16:51:21:Listening




  • 8.  RE: Trouble setting up Delphix database user

    Posted 12-03-2015 09:27:00 PM
    Will email you the target log, since its too large to cut and paste