Delphix Toolkit (dxToolkit)

Expand all | Collapse all

dx_provision_vdb Error

Jump to Best Answer
  • 1.  dx_provision_vdb Error

    Posted 04-16-2018 05:50:00 PM
    I am trying to provision a VDB using dxtoolkit , dx_provision_vdb but getting these errors  - 
    Problem with starting job
    Error: source->allowAutoVDBRestartOnHostReboot->This field is required.
    error $VAR1 = {
              'source' => {
                            'allowAutoVDBRestartOnHostReboot' => {
                                                                   'details' => 'This field is required.',
                                                                   'commandOutput' => undef,
                                                                   'action' => undef,
                                                                   'id' => 'exception.validation.field.missing',
                                                                   'diagnoses' => undef
                                                                 }
                          }
            };
    $VAR2 = 1;

    Job wasn't defined. If there is no error on the screen, try with -debug flag to find a root cause.


    Is there a different Tag that needs to be appended with the query ??
    #dxToolkit


  • 2.  RE: dx_provision_vdb Error
    Best Answer

    Posted 04-16-2018 07:35:00 PM
    Hello Kinjal,
                        Looks like you need to pass set the parameter "allowAutoVDBRestartOnHostReboot" while provisioning a VDB.

    Please share the full command with parameters, which you run to provision VDB, using dx_provision_vdb.

    ~Thanks


  • 3.  RE: dx_provision_vdb Error

    Posted 04-16-2018 07:43:00 PM
    Hello,

    You can also have a older version of dxtoolkit which doesn't support 5.2 engines.
    I would suggest upgrade to a latest version.

    regards,
    Marcin


  • 4.  RE: dx_provision_vdb Error

    Posted 04-16-2018 07:46:00 PM
    Hi Kinjal, The parameter “allowautovdbrestartonhostreboot” is mandatory as per engine version 5.0 and upper. As Jatinder stated you have to set a value for this parameter to get the command running Regards, Mouhssine