Delphix Products

Expand all | Collapse all

Failed to discover environment variable $SYBASE

Jump to Best Answer
  • 1.  Failed to discover environment variable $SYBASE

    Posted 03-22-2019 11:37:00 AM
    I created the settings for the user delphix_os on host, but i have same problem with variable $SYBASE.  I made some setting for ssh.

    1)«PermitUserEnvironment»  -«yes».

    2)I create .ssh/environment file and add
    SYBASE = /opt/sybase/ase157

    3)restart ssh

    I tried to create an environment but got an error:

    Failed to discover environment variable $SYBASE on host

    Make sure that environment variable is set for user
    #Virtualization


  • 2.  RE: Failed to discover environment variable $SYBASE

    Posted 03-22-2019 11:46:00 AM
    Hello,

    I'm not sure what operating system and its version you are using?

    It sounds like you have set the options correctly but can you show us the results of the following command?
    cat .ssh/environment

    And then the way you can test whether or not the environment variable is set for non-interactive logins is by executing the following command:
    ssh delphix_user@ase_hostname env | grep SYBASE




  • 3.  RE: Failed to discover environment variable $SYBASE
    Best Answer

    Posted 03-22-2019 12:07:00 PM
    I solved my problem.

    I have  gap in SYBASE = /opt/sybase/ase157. Correct is SYBASE=/opt/sybase/ase157.

    Thanks.


  • 4.  RE: Failed to discover environment variable $SYBASE



  • 5.  RE: Failed to discover environment variable $SYBASE
    Best Answer

    Posted 04-04-2019 08:42:00 AM
    Hi, i solved it. I chose New Full Backup.

    Thanks for answer.