API/Python/Open-Source Solutions

Expand all | Collapse all

can't import delphixpy.delphix_server

Jump to Best Answer
  • 1.  can't import delphixpy.delphix_server

    Posted 09-25-2016 03:05:00 PM
    Hey,
    I'm using the delphixpy package but when I'm trying to import the delphix_server I got ImportError: No module named delphix_server. Is this module was removed from delphixpy?

    Thanks
    #Masking
    #DemoEnvironment


  • 2.  RE: can't import delphixpy.delphix_server
    Best Answer

    Posted 09-26-2016 03:08:00 PM
    Luiza, a while ago we changed from delphix_server to DelphixEngine. Take a look at my Github for examples. https://github.com/CloudSurgeon/delphixpy-examples


  • 3.  RE: can't import delphixpy.delphix_server

    Posted 09-27-2016 11:43:00 AM
    Thanks!


  • 4.  RE: can't import delphixpy.delphix_server

    Posted 04-05-2017 01:55:00 PM

    Hi Adam,

    I am getting the same error. is this environment setup issue?


    python list_all_databases.py
    Traceback (most recent call last):
      File "list_all_databases.py", line 2, in <module>
        from delphixpy.v1_6_0.delphix_engine import DelphixEngine
    ImportError: No module named delphixpy.v1_6_0.delphix_engine
    bash-4.1$


    I see module are there:

    /opt/sybase/dba/delphixpy-1.8.0.0/build/lib/delphixpy/v1_6_0
    bash-4.1$ ls -ltr
    total 48
    -rw-r--r--  1 sybase sybasedv  1996 Sep 27  2016 response_validator.py
    -rw-r--r--  1 sybase sybasedv  2061 Sep 27  2016 job_context.py
    -rw-r--r--  1 sybase sybasedv   194 Sep 27  2016 __init__.py
    -rw-r--r--  1 sybase sybasedv  5897 Sep 27  2016 http_client.py
    -rw-r--r--  1 sybase sybasedv  1592 Sep 27  2016 factory.py
    -rw-r--r--  1 sybase sybasedv  1870 Sep 27  2016 exceptions.py
    -rw-r--r--  1 sybase sybasedv 11038 Sep 27  2016 delphix_engine.py
    -rw-r--r--  1 sybase sybasedv  2103 Sep 27  2016 common.py
    drwxr-xr-x 38 sybase sybasedv  4096 Feb  7 11:06 web
    bash-4.1$ pwd
    /opt/sybase/dba/delphixpy-1.8.0.0/build/lib/delphixpy/v1_6_0
    bash-4.1$