Delphix Products

Expand all | Collapse all

exception.ase.environment.enwar.sybase.net_set

Jump to Best Answer
  • 1.  exception.ase.environment.enwar.sybase.net_set

    Posted 08-28-2017 07:07:00 AM
    Failed to discover environment variable $SYBASE on host "160.80.38.6"

    #Virtualization


  • 2.  RE: exception.ase.environment.enwar.sybase.net_set
    Best Answer

    Posted 08-28-2017 12:37:00 PM
    Hi Danny,

    This is very common when the SYBASE environment variable is not set properly for non-interactive logins. You can test to see if it is defined for non-interactive logins like this:

    ssh delphixosuser@160.80.38.6 env | grep SYBASE

    Depending on what operating system and shell the user runs under means there are different ways to make sure the variable is set for non-interactive logins.

    Thanks,
      Neal


  • 3.  RE: exception.ase.environment.enwar.sybase.net_set

    Posted 08-29-2017 01:59:00 AM
    I have tried but I could not find the value of "SYBASE".

    How can I set this environment variable?


  • 4.  RE: exception.ase.environment.enwar.sybase.net_set

    Posted 08-29-2017 12:13:00 PM
    Hello,

    What operating system are you on?

    What shell does your user default to (echo $SHELL)? You may need to export SYBASE in .bashrc or .bash_profile .

    I've seen a couple of instances where customers need to:
    • Add the parameter PermitUserEnvironment=yes in the sshd_config file. I'm not sure but this may require a restart of the sshd by the UNIX administrator.
    • Add SYBASE and PATH variable in the user's ~/.ssh/environment file.
    Thanks,
      Neal