Add Dataset Home Maria DB - Error

  • 0
  • 1
  • Idea
  • Updated 3 months ago
  • Not Planned
Hi to all,

I'm trying to add a MariaDB as dataset, when i specify the home path and press "add" I receive the following error message
Skipped discovery for MySQL install "/var/lib/mysql" as it is an unsupported release "10.1.34MariaDB MariaDB"
In compatibility matrix https://docs.delphix.com/docs/release-information/release-notes-5-2-x/support-matrices/masking-data-... I can see thath MariaDB 10 is supported.

Is there any check i can perform?

Thanks in advance,
Andrea
Photo of Andrea Cavallieri

Andrea Cavallieri

  • 90 Points 75 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Neal Stack

Neal Stack, Official Rep

  • 2,592 Points 2k badge 2x thumb
Hello,

The link you have provided is for the Delphix Masking product. They do not go into the specifics of whether or not the support 10.0.x versus 10.1.x but I would venture to guess you should be able to mask a physical MySQL 10 database.

Delphix stopped supporting MySQL in Delphix version 5.0 though they may bring support back for it in the future. Even though Delphix stopped supporting MySQL, the functionality is still in the product so you could link to a supported version of MySQL source database and provision VDBs.

Delphix 5.0->5.2 works with MySQL 10.0. It does not support MySQL 10.1.x: https://docs.delphix.com/display/DOCS50/Supported+Operating+Systems+and+Database+Versions+for+MySQL+Environments

Thanks,
  Neal