After successful execution of masking jobs, why VDB is not showing as masked in delphix server?

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered

I have created some masking jobs, like name, lastname, phone, DL, SSN. All jobs are successfully executed and verify jobs are also executed, which are working fine. Content is also validated and looks working fine. I am facing 2 challenges:

1. Though, data is masked, but VDB is not showing as Masked, like with a symbol of "M"

2. The masking jobs are enabled with Multitenant, but still jobs are not displaying when I want to associate these jobs with dSource, so I can create new VDB with masked data.

Appreciate your thoughts !!


Photo of santosh kumar

santosh kumar

  • 350 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
Official Response
1) Only when you provisioned a Masked VDB it will have that icon, i.e. only when you attached the masking job to the VDB in the provisioning window and the job was executed as part of the provisioning. You'll find the whole process documented here:https://docs.delphix.com/docs/delphix-masking/delphix-masking-quick-start-guide/provisioning-masked-...
In contrast, when you provision a VDB first and then run masking jobs from the masking GUI against that VDB, the VDB is still a normal VDB (it was provisioned without masking and you just happened to later run masking jobs against it) and doesn't get the masked icon.

2) You need to add the multi-tennant job to the parent (dSource or parent VDB). Only then you will get it in the selection box of the provisioning window. Masking jobs that are already added to any other dSource/VDB can't be added to a second dSource/VDB.This is also described in the documentation at above link.