After successful execution of masking jobs, why VDB is not showing as masked in delphix server?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered

I have created some masking jobs, like name, lastname, phone, DL, SSN. All jobs are successfully executed and verify jobs are also executed, which are working fine. Content is also validated and looks working fine. I am facing 2 challenges:

1. Though, data is masked, but VDB is not showing as Masked, like with a symbol of "M"

2. The masking jobs are enabled with Multitenant, but still jobs are not displaying when I want to associate these jobs with dSource, so I can create new VDB with masked data.

Appreciate your thoughts !!


Photo of santosh kumar

santosh kumar

  • 620 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 5,466 Points 5k badge 2x thumb
Hi santosh,

I guess that you run the job directly from the making interface. (Is it right ??)

Answer to you questions if the response is yes to mine

2 ) refresh or logout/login back from/to the admin interface you will see a fetch job running that will detect the masking job you've created you will have to associate it with your dsource

1) maybe this is a GUI bug, but try running a create or refresh of vdb after you've applied the step 2 above and you will see the icone

Regards

Mouhssine
Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
Official Response
1) Only when you provisioned a Masked VDB it will have that icon, i.e. only when you attached the masking job to the VDB in the provisioning window and the job was executed as part of the provisioning. You'll find the whole process documented here:https://docs.delphix.com/docs/delphix-masking/delphix-masking-quick-start-guide/provisioning-masked-...
In contrast, when you provision a VDB first and then run masking jobs from the masking GUI against that VDB, the VDB is still a normal VDB (it was provisioned without masking and you just happened to later run masking jobs against it) and doesn't get the masked icon.

2) You need to add the multi-tennant job to the parent (dSource or parent VDB). Only then you will get it in the selection box of the provisioning window. Masking jobs that are already added to any other dSource/VDB can't be added to a second dSource/VDB.This is also described in the documentation at above link.
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 5,466 Points 5k badge 2x thumb
Hi Karsten,

Thanks for the update

@ santosh :

You have to recreate the vdb after attaching the masking job to the dsource only this way you will end up with the masking icone.

Regards,

Mouhssine
Photo of santosh kumar

santosh kumar

  • 620 Points 500 badge 2x thumb

Thanks for details that you provided.

Karsten @ I went through the link that you mentioned above and verified masking jobs again and all are enabled with multitenant, but still not able to see masking rules while associating to dSource. Please let me know what is missing here.

Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 5,466 Points 5k badge 2x thumb
Hi,

Refresh the admin console or logout and login back to the admin and it will show up.

Regards

Mouhssine
Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
@santosh: Are you using a separate masking engine or do you run masking and virtualization on the same DE?
Photo of santosh kumar

santosh kumar

  • 620 Points 500 badge 2x thumb

I followed above step to refresh and logoff/login, but nothing is changed.

Karsten @ I am using separate masking engine as masking engine is logged on with local user credentials and delphix engine is logged on LDAP (domain login)

Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
That's good as it's recommended to use s split engine config. But you need to tell the virtualization engine where to find the masking engine. This can only be set through the command line interface. I'll send you a link later.
Photo of santosh kumar

santosh kumar

  • 620 Points 500 badge 2x thumb

Can you please provide the link that you mentioned above. I can try and get back to same forum if any issues..

Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
Sorry for the delay. When logging into the CLI of your virtualization engine with your delphix_admin user you go to maskingjob serviceconfig. However, when this is first time you won't have the commands to change the config. Your engine first needs to be enabled for a split engine configuration. This is done by setting a feature flag which only Delphix Support can set in your engine. Please raise a support ticket asking to set the feature flag REMOTEDMS in order to enable a split engine configuration.
Photo of santosh kumar

santosh kumar

  • 620 Points 500 badge 2x thumb
Thanks Karsten. We logged a ticket and delphix team helped us to resolve the issue by adding communication between delphix engine to masking engine. I am able to see the masking jobs while creating child VDB.