API: Scan name null in "environment" call after upgrading from Delphix 4.0 to 4.1

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
I made a call to:

http:///resources/json/delphix/enviro...

And before, using Delphix 4.0, I would get a "scan" containing the scan address of the Oracle cluster.

After upgrading our Delphix Engine to 4.1, the scan name is now showing as null.

Anyone know what's the issue here?
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
  • concerned

Posted 4 years ago

  • 0
  • 1
Photo of Jiangbin Luo

Jiangbin Luo

  • 90 Points 75 badge 2x thumb
Does the scan name shows up in the GUI, or CLI?
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
Unsure how to check that in the GUI, but here is the response from the CLI:

dhcp-<redacted> environment "CDLENTEF8"> get    type: OracleCluster
    name: CDLENTEF8
    clusterUser: CDLENTEF8/oracle
    crsClusterHome: /oracrs/product/grid/1123/gd1
    crsClusterName: cdlentef8dbcrs
    description:
    enabled: true
    primaryUser: CDLENTEF8/oracle
    reference: ORACLE_CLUSTER-7
    remoteListener: (unset)
    scan: (unset)
    scanManual: false
    version: 11.2.0.4.0
Photo of Jiangbin Luo

Jiangbin Luo

  • 90 Points 75 badge 2x thumb
That means the scan was not (re)discovered after the upgrade.
Could you try to run the following command on one of the cluster host, and see what the result is?

/oracrs/product/grid/1123/gd1/bin/srvctl config scan
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
I just ran that command on one of the cluster hosts, and here is the result:

/oracrs/product/grid/1123/gd1/bin/srvctl config scanSCAN name: <scan-name-here>, Network: 1/<ip-redacted>/255.255.255.0/<vlan-redacted>
SCAN VIP name: scan1, IP: /<scan-name-here>/<ip-redacted>
SCAN VIP name: scan2, IP: /<scan-name-here>/<ip-redacted>
SCAN VIP name: scan3, IP: /<scan-name-here>/<ip-redacted>



I've redacted the scan name and the relevant ips for security reasons... the name and the ips are correct.
(Edited)
Photo of Jiangbin Luo

Jiangbin Luo

  • 90 Points 75 badge 2x thumb
Everything looks normal. I would suggest you refresh the cluster environment from Delphix engine again. If scan still doesn't show up, you could either manually edit the scan through CLI or file a support request so that we can diagnose the issue.
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
I can't reset right now because the environment is in use (and refreshing the environment stops VBbs). I will try the refresh during a maintenance window and report back with the results - I expect the refresh will solve the issue.
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
I was able to refresh one of our other environments, and unfortunately, the issue was not resolved.

EDIT: Comment got clipped. The scan name is showing as null in the API and unset in the CLI.
(Edited)
Photo of Jiangbin Luo

Jiangbin Luo

  • 90 Points 75 badge 2x thumb
If you can run "srvctl config scan" successfully on the environment (that means every host of the cluster) you refresh, this might be caused by a failure to discover the scan name. As I mentioned before, this would need a support call to get diagnosed and resolved.
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb
I initally ran srvctl config scan on just one of the hosts, but I can also now confirm that every host in this particular 4-node cluster can perform this command.

I've opened up a support ticket and someone is looking into the issue-- thanks.