Assigning IP Address to Delphix Source

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi, Recently i had downloaded Delphix Trial. I could able to successfully mount OVA(s) in our VM(s) for Delphix Engine and Delphix Target as per the Installation Guide and I can see the Generated IP. But when I was trying the same with Delphix Source I am getting Issue(s). It was mounted successfully and I am able to login with Username: "delphix" and Password as "delphix". But its nowt shwing me the IP Address. Is there a way to resolve this. Please help me.
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
  • Confused

Posted 2 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Does the VM have an IP address?

what is the output of ifconfig on the LinuxSource?
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Yeah VM is having an IP Address Associated with it. Ifconfig is showing me some Lanshark configuration details. But no where IP Address is displaying.
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
I had unmounted it and mounting it again. Its in Progress. Will take another 1 or 2 hours to complete the process.
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
If ifconfig did not show an IP address, then your VM did not have an ip address. 
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Even after mounting it again for the second time. I have got the same issue. But I can login to the Source Using Username : delphix and Password : delphix.

Is there a way to assign an IP to the VM with the above login credentials.
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Show me the output of `ifconfig -a` from the LinuxSource
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,782 Points 4k badge 2x thumb
Hi,

Plesae check vm settings ensure that for network adapter the check box "connect on power" is checked.

If it's the case follow Adam's recommandation by posting the output of "ifconfig -a" command.

Mouhssine
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Hi Adam, 

Thanks for the reply. Actually I am out of office. I will post you the output on Monday Morning IST. 
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb

Hi Adam,


Attached is the ifconfig Output.

Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Ok. So it looks as though your LinuxSource is only being assigned an IPV6 address, and not an IPv4 address. (You can compare that to how ifconfig -a looks on your LinuxTarget). Ensure that the LinuxSource is on the same network as the LinuxTarget and Delphix Engine. You might also need to look closer at your network's DNS scope.

If you want to just go with a static address, and you understand some basic Linux,  then you can do this

IPADDR=<The IP Address you want the VM to have>
BROADCAST=<The Broadcast address>
NETMASK=<The subnet mask of your LINUXSOURCE IP>
GATEWAY=<The default gateway for your LINUXSOURCE>

sudo cp /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.bak
sudo cat > /etc/sysconfig/network-scripts/ifcfg-eth0 <<-EOF
DEVICE=eth0
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=static
IPADDR=$IPADDR
BROADCAST=$BROADCAST
NETMASK=$NETMASK
GATEWAY=$GATEWAY
EOF

sudo service network restart
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb

Hi Mouhssine SAIDI ,


Thanks for the Solution. I had checked the VM configuration and Mounted the OVA again. It worked for me. Thanks a lot.


Thanks a lot Adam.