Attempting to Connect to XE Source Employee Virtual App fails

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Delphix Engine Dashboard works OK. Set up the XE Source Employee Virtual App on port 2080. Attempting to connect to it with Firefox. Failed

Note: This conversation was created from a reply on: Virtual Box on Mac Book Pro : Network Inferface not configured - please advise.
Photo of Bryan

Bryan

  • 190 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Failed as in fails to connect? Or fails as in you get a specific error message in the browser? Can you provide a screenshot of the Employee Virtual app card? Click on it in Delphix and then click the Open button (looks like an arrow popping out).
Photo of Bryan

Bryan

  • 190 Points 100 badge 2x thumb
The screenshots have been uploaded.  Thanks
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Where did you upload the screenshots? You can attach them to a post by clicking the little camera button below your text in the comment box.
Photo of Bryan

Bryan

  • 190 Points 100 badge 2x thumb
Yep, I did that.  They were there .. then disappeared.  I'll have another go
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Can you ssh into the Linux Source? What is the output of netstat -an | grep 2080 and ps -ef | grep apache?  A text scrape will suffice.
Photo of Bryan

Bryan

  • 190 Points 100 badge 2x thumb
delphix@linuxsource ~]$ netstat -an | grep 2080
tcp        0      0 :::2080                     :::*                        LISTEN     

[delphix@linuxsource ~]$ ps -ef | grep apache
delphix   1737     1  0 07:47 ?        00:00:12 /usr/java/jdk1.7.0_51/bin/java -Djava.util.logging.config.file=/home/delphix/apache-tomcat-7.0.42/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=/home/delphix/apache-tomcat-7.0.42/endorsed -classpath /home/delphix/apache-tomcat-7.0.42/bin/bootstrap.jar:/home/delphix/apache-tomcat-7.0.42/bin/tomcat-juli.jar -Dcatalina.base=/home/delphix/apache-tomcat-7.0.42 -Dcatalina.home=/home/delphix/apache-tomcat-7.0.42 -Djava.io.tmpdir=/home/delphix/apache-tomcat-7.0.42/temp org.apache.catalina.startup.Bootstrap start
delphix   5143     1  0 08:17 ?        00:00:09 /usr/bin/java -Djava.util.logging.config.file=/home/delphix/apache-tomcat-7.0.42_xe/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=/home/delphix/apache-tomcat-7.0.42_xe/endorsed -classpath /home/delphix/apache-tomcat-7.0.42_xe/bin/bootstrap.jar:/home/delphix/apache-tomcat-7.0.42_xe/bin/tomcat-juli.jar -Dcatalina.base=/home/delphix/apache-tomcat-7.0.42_xe -Dcatalina.home=/home/delphix/apache-tomcat-7.0.42_xe -Djava.io.tmpdir=/home/delphix/apache-tomcat-7.0.42_xe/temp org.apache.catalina.startup.Bootstrap start
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Ok, so we know it is actually running and listening on that port. Can you double-check the ip address in your firefox browser? Do you see any error messages in the bottom of /home/delphix/apache-tomcat-7.0.42_xe/logs/catalina.out ?
Photo of Bryan

Bryan

  • 190 Points 100 badge 2x thumb
Ah .. got it .... the ip I was using was the Delphix Engine VM.. as opposed to the Source machine !
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
No problem. It happens. I'll mark this thread as solved.