Can't associate a Masking Job with the dSource

  • 1
  • 1
  • Question
  • Updated 3 months ago
  • Answered
Hi all,

as described here: https://docs.delphix.com/display/DOCS50/Provisioning+Masked+VDBs#ProvisioningMaskedVDBs-AssociateaMa...

I should have been able to select a masking job to associate with the dSource, but I can't see any job in the right window. The job is rightly configured in the masking server with the option "Multi Tenant" enabled. What do I have to check again?
Thank you.
Gianpiero
Photo of Gianpiero Piccolo

Gianpiero Piccolo

  • 2,336 Points 2k badge 2x thumb

Posted 2 years ago

  • 1
  • 1
Photo of Ganesh Sundaresan

Ganesh Sundaresan, Employee

  • 588 Points 500 badge 2x thumb
Official Response
Hi Gianpiero

You may want to refresh the browser OR try logging out and login again OR try to use a different browser altogether.

Hope this helps

thanks
Ganesh
Photo of Gianpiero Piccolo

Gianpiero Piccolo

  • 2,336 Points 2k badge 2x thumb
God bless you! You saved me.
Closed and reopened my Google Chrome and .... voila! The job appeared!
Photo of Brian Parrella

Brian Parrella

  • 60 Points

"Multi Tenant" wasn't helping me. The only solution for me was to run these commands on the Delphix engine:


delphix1> maskingjob
delphix1 maskingjob> fetch
delphix1 maskingjob fetch *> commit
    Dispatched job JOB-81535
    MASKINGJOB_FETCH job started for "unknown".
    MASKINGJOB_FETCH job for "unknown" completed successfully.
delphix1 maskingjob>



Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb

Hi Gianpiero,

It seems you are using a delphix version lower than 5.2, and the cause of this behavior is flush (yes you can blame it).

Just notice that this disappears within the newer version 5.2 and upper because of no more flush usage (thanks JS and HTML5)

Regards,

Mouhssine

Photo of Gianpiero Piccolo

Gianpiero Piccolo

  • 1,466 Points 1k badge 2x thumb
Did you mean "flash" (Adobe browser component)?
Thank you for your info.
Gianpiero
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb

Yep, that's it.

You can do a simple test as follows :

0/ connect to admin console
1/ connect to masking console and create a new masking job
2/ try to associate the new job with a dsource
>> you will not see your new created job
3/ refresh the admin console and notice in action menu <fetching masking job>
>> this means that virtualization engine is asking if there is any new masking job to get from masking engine
4/ check back the dsource you will see the masking job new and can associate it

Flash is bad this is one of the reasons that everyone moves to new technologies like HTML5, JS and so (delphix did it with the move to 5.2)

You ha a great paper one delphix's blog about that cf. https://www.delphix.com/fr/blog/eliminate-flash

Regards,

Mouhssine
(Edited)
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb
sorry for mistaken typo flash and not fluch :)