Delphix Engine installation is failing at registration step.

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Delphix Engine installation is failing at registration step. Error Message "Cannot connect to HTTP server "https://register.delphix.com"; . Make sure the proxy settings are correct
Photo of Narasimharao Konduri

Posted 4 years ago

  • 0
  • 1
Photo of Ranzo Taylor

Ranzo Taylor, Employee

  • 1,666 Points 1k badge 2x thumb
Official Response
The connection is attempted from the Delphix Engine, not from your PC browser.  This error is telling you that the Engine cannot reach the Delphix Corporate servers on the internet, like register.delphix.com.  It's often the case that Delphix is behind firewalls which do not allow connection to the internet at all.  A Web Proxy can be used to securely connect to the internet, but you have to configure this correctly during the setup.

I hope this helps you troubleshoot the error.
Photo of Kyle Hailey

Kyle Hailey, Alum

  • 878 Points 500 badge 2x thumb
Are you using a proxy? Are there firewalls?

What shows up as your DNS server IP on the 3rd install screen shown below?



You can try changing the DNS server.  You can try using Google's DNS server 8.8.8.8
If after changing the server, you still have the error, try shutting down the Delphix engine, rebooting and trying again.

- Kyle
I still get the same error/

the issue is resolved now but I am not able to see the source and target databases in the web console. also not able to view the folders (Dev, QA etc.,)


I am able to ping to source and target from VM console.


any help is highly appreciated!

Photo of Amit Bansal

Amit Bansal

  • 150 Points 100 badge 2x thumb
Hi Kyle/Narsimhara,

I'm also facing this same registration issue. Could you please suggest the solution?

Thanks,
Amit
Photo of Kyle Hailey

Kyle Hailey, Alum

  • 878 Points 500 badge 2x thumb
Hi

  What resolved the DNS issue?
   
  What hypervisor are you using ? Vmware or Virtualbox.

  To analyze the auto configuration, log onto the target box as delphix.

   You can check to see if the autoconfig is running by searching for a process called "lanshark_setup.py"
  • $ ps -ef | grep land
  • delphix   1602  1600  0 13:22 ?   /usr/local/bin/python2.7 /home/delphix/landshark_setup.py

If it is running you can tail the log file to see how it is going

  • tail -f  landshark_setup.log
If the process is not running you can run it
  • nohup ./landshark_setup.py &
By default, the auto configuration running on the target will try and discover the source machine and the Delphix engine. You can over ride this and specify the exact IP address of the source and Delphix machine. To do so go to the  URL of the target on port 8000
you can set
  • discovery_enabled = FALSE
  • linux_source_ip = IP of the source machine
  • engine_address = IP of Delphix engine
click "Submit Changes" at the bottom of the page to save the changes

Have you seen the quick start guide here?

https://docs.delphix.com/display/LS22/Quick+Start+Guide+for+the+Delphix+Landshark+Environment

Best Wishes
Kyle Hailey

After running the script from target machine you have provided, it has created the dev, qa, analytics, copies. but I still do not see the XEXE and the webapp. Can you please look into the issue

Thanks

Narasimha

Photo of Kyle Hailey

Kyle Hailey, Alum

  • 878 Points 500 badge 2x thumb
Could you post a screen shot of your Delphix console?


Thanks
Kyle
Please find the screen shot of the console and also the screenshot of the target linux machine

Photo of Kyle Hailey

Kyle Hailey, Alum

  • 878 Points 500 badge 2x thumb
I'm wondering if there is a memory or CPU issue as the auto-configuration has a timeout and the screen shot of the web UI shows that it hasn't fully refreshed.

How much memory do you have on your install machine? How many CPU cores? Are there other large programs running at the same time?

 Can you log out and back in to see if the web UI refreshes fully?

As far as the auto-configuration timeout, you can stop are restart the auto-configuration script and it should finish up on it's own as I outlined in my earlier comment about /home/delphix/landshark_setup.py


Thanks
Kyle

Thanks Kyle. The issue is resolved now and I am able to see both the dSources.

But delphix engine seems to slow down entire system.

I am using Dell Inspiron 15 Intel Pentium 3 dual core with 8GB RAM and 500GB HDD

Photo of Kyle Hailey

Kyle Hailey, Alum

  • 878 Points 500 badge 2x thumb
Yes, the Delphix is set up for 2G of RAM as well as each of the target and server are set up for 2G making a total of 6G and this will definitely have an impact on an 8G RAM machine.

- Kyle
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,886 Points 10k badge 2x thumb
In addition to Kyle's questions, I have seen that this issue (HTTP socket timeout) is commonly caused because of being on a public wifi (hotel, cafe, starbucks, etc). If this is on your laptop on wifi, I would try disabling my wifi and then seeing if the installation proceeds (if the process is stopped, start it again).
Photo of Amit Bansal

Amit Bansal

  • 150 Points 100 badge 2x thumb
Hi Kyle/Narsimhara,

I'm also facing this same registration issue. Could you please suggest the solution?

Thanks,
Photo of Amit Bansal

Amit Bansal

  • 150 Points 100 badge 2x thumb
Hi Kyle/Narsimhara,

I'm also facing this same registration issue. Could you please suggest the solution?

Thanks in Advance