Delphix with SQL 2014 Avaialbility groups

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
Hi,

I am having trouble with Adding one of the SQL 2014 AG cluster with Delphix.

This what I did so far.

Added the windows cluster where SQL 2014 AG resided as source environment.  I already have PPT server registered as target environment.

Now I go and add a dsource,  IDelphix engine somehow not displaying the database names in AG.
Photo of Bhanu Naidu

Bhanu Naidu

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Darin Tully

Darin Tully, SQL DBA

  • 530 Points 500 badge 2x thumb
Official Response
Hi Bhanu,

If the databases are not listed in the AG, one reason could be the AG does not have a listener. And another reason could be the AG was added as a stand-alone Source environment and was not added as a Clustered Source environment. If the AG was added correctly, there should be a "Clustered Nodes" section on the Environment Details tab for the AG environment.
Photo of Guillaume Nocent

Guillaume Nocent

  • 110 Points 100 badge 2x thumb
Check also if the accounts used by your Delphix Engine and Staging server have VIEW ANY DEFINITION and VIEW SERVER STATE privileges (or, finer, VIEW DEFINITION ON AVAILABILITY GROUP::[agname]).
Photo of Bhanu Naidu

Bhanu Naidu

  • 110 Points 100 badge 2x thumb
Thank you Both. These are the step I followed for setting up AG

1. Set up listener
2. Granted admin access to Account used on both Delphic engine and PPT 

In my case,  There was an issue with reverse look up entry in windows cluster.  We corrected it and now able to register databases which are in AG.

Thanks again to both of you.