Diffirential/Incrementel Snapshot for SQL server problem

  • 1
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi

This is Delphix demo butt is not landshark. I am now trying to do POC and ;

Maybe I am missing something maybe there is bug on my systems.

Here is What I did

I added my environments source,validated sync, target1 and target2
I run discover and after that I added dsource for each database, recovered from source environment by engine
While adding this dsource I select backup location autodiscover, transaction log and logsync enabled, for other backup options on the dsource menu I did not select any ( full backup, full backup or differential backup, none )
So When I click next next and finish. Snapshot is started but It gave me an error ( I think it is trying to backup up transaction logs but there is no full backup yet so it should be normal )
I went on to start snapshot for the first time " Delpix will take a copy-only backup of your source database" ....

Until here everything is ok because there is no full backup and I think I can not add dsource for the first time with "transaction logs" so I did full backup for the first snapshot
but After this first snapshot is completed I should be able to start snapshot again with the option " Use the most recent full or differential backup " ?

But I am getting warning " Delphix Engine has already applied the database backup with UUID "748E11...." so I can't take encrymentel/differential or whatever it is for my source SQL database

I can't find any clear documents on docs.delpix.com so If I am enough clear to explain my case Please help me or tell me if you need any extra information.

By the way please consider this source environment is a Test environment which is for POC ( Recovery Mode : Full )
Photo of Cihan

Cihan

  • 300 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Official Response
If you tell Delphix to create a snapshot from the most recent backup, and Delphix already has used that backup for that dSource or has created a more recent backup via copy-only backup, you will get the "Delphix Engine has already applied the database backup with UUID ...." message as Delphix will not load it twice. If you want to take a new snapshot in the manner you describe, then create a new backup of the source database. Delphix will be able to ingest that.