dx_provision_vdb Error

  • 0
  • 1
  • Question
  • Updated 7 months ago
  • Answered
  • (Edited)
I am trying to provision a VDB using dxtoolkit , dx_provision_vdb but getting these errors  - 
Problem with starting job
Error: source->allowAutoVDBRestartOnHostReboot->This field is required.
error $VAR1 = {
          'source' => {
                        'allowAutoVDBRestartOnHostReboot' => {
                                                               'details' => 'This field is required.',
                                                               'commandOutput' => undef,
                                                               'action' => undef,
                                                               'id' => 'exception.validation.field.missing',
                                                               'diagnoses' => undef
                                                             }
                      }
        };
$VAR2 = 1;

Job wasn't defined. If there is no error on the screen, try with -debug flag to find a root cause.


Is there a different Tag that needs to be appended with the query ??
Photo of Kinjal Gala

Kinjal Gala

  • 90 Points 75 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Jatinder Luthra

Jatinder Luthra, Employee

  • 2,996 Points 2k badge 2x thumb
Hello Kinjal,
                    Looks like you need to pass set the parameter "allowAutoVDBRestartOnHostReboot" while provisioning a VDB.

Please share the full command with parameters, which you run to provision VDB, using dx_provision_vdb.

~Thanks
Photo of fMarcin Przepiorowski

fMarcin Przepiorowski, Employee

  • 870 Points 500 badge 2x thumb
Hello,

You can also have a older version of dxtoolkit which doesn't support 5.2 engines.
I would suggest upgrade to a latest version.

regards,
Marcin
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,782 Points 4k badge 2x thumb
Hi Kinjal,

The parameter “allowautovdbrestartonhostreboot” is mandatory as per engine version 5.0 and upper.

As Jatinder stated you have to set a value for this parameter to get the command running

Regards,

Mouhssine