Error in creating VDB (Delphix on AWS)

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)

We have been trying to create VDB and received the following error message (the dSource is registered successfully).

Command Output says:
" ERROR : SQL> LRM-00109: could not open parameter file '/delphix/Vprorize_81B/datafile/init.ora.rename' "

It seem that the target db server has not been NFS mounted to /delphix. 

What should we do for this?

Photo of Yasu


  • 412 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of David Gillespie

David Gillespie, Employee

  • 1,010 Points 1k badge 2x thumb
Hi Yasu,
There could be a number of issues but an easy one to check first is to verify that /delphix is owned by the delphix_os user that you are using to provision the VDB with as well as the verify that it has rx for group and world. 
Therefore if you are using oracle as the delphix_os user then /delphix should be owned by oracle and it's permissions should be set to 755.
Dave G.
Photo of Yasu


  • 412 Points 250 badge 2x thumb
Hi Dave,

Confirmed as follows:

/delphix (target DB server)

owner    delphix_os
group    oinstall
mode    755

any other items that we should check?

Thank you,
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Is there currently anything in the /delphix directory? Are you provisioning the VDB as delphix_os, or as oracle?

As a test, change the permissions of /delphix to 777. Then try a provision. If it is successful, do a ls -la on /delphix and see who the folder is mounted as.
Photo of Paul Dagnelie

Paul Dagnelie, Employee

  • 150 Points 100 badge 2x thumb
It is probably worth verifying that the nfs port is not blocked by your security group for either the delphix engine or the target environment.  Port 2049 is allocated to nfs; is it allowed for both tcp and udp on both the target and the Delphix Engine?
Photo of Yasu


  • 412 Points 250 badge 2x thumb
Thank you, David, Adam, Paul, 

The problem has been solved.