Error in liking a dSource

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved

Hello,

We have encountered an error message when we try to link a dSource and would very much appreciate if someone could answer this (we are using an AWS environment).

We have been trying to set up the server, referring "Delphix Engine 4.1 Documentation - Quick Start Guide for the Delphix Engine Oracle Quick Start Topics"

We were successfully able to set up an Oracle instances, but were unable to link an Oracle Data Source.

Here is the procedure we took: 

4.Enter your login credentials for the source database and click
 Verify Credentials. If you are linking a mounted standby,
 click Advanced and enter non-SYS login credentials as well.-> Click Next.

After entering "SYS" for DB username and "SYS" for DB userpassword, we get the following error message.

"Unable to connect to source database "prorize" using the provided credentials,
 due to: Cannot connect to database due to: Exception occurred while getting connection:
 oracle.ucp. UniversalConnectionPoolException: Cannot get Connection from Datasource:
 java.sql.SQLRecoverableException: IO Error: The Network Adapter could not establish
 the connection"

Is there anyone who has seen the same error message and know how this should be resolved?

 Thanks,

Yasu
Photo of Yasu

Yasu

  • 412 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
are you able to sqlplus to that database with those credentials? Is the Delphix Engine in the same availability zone as the source?
Photo of Yasu

Yasu

  • 412 Points 250 badge 2x thumb
Thank you, Adam.

Yes. We are able to sqlplus to that database with sys/XXXX@SQL*Netsrings as sysdba and the Delphix Engine is in the same availability zone as the source.
Photo of Yasu

Yasu

  • 412 Points 250 badge 2x thumb
Thank you. The problem is resolved now.

Yasu
Photo of Benoit Contri

Benoit Contri

  • 72 Points
Hi Yasu,

Can you confirm the actions you've done to resolve your issue.

I'm hating the same thing with my cluster configuration.

Regards,

Mouhssine