eth0 vmware-tools pre-start proces terminated with status 1

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I'm having this problem on Target and Source machine. Im using vmware fusion on Mac

Both machines have this issue on boot where both freezes with following error message: Bringing up interface eth0
Determining IP information for eth0...init: vmware-tools pre-start proces (784) terminated with status 1
Photo of Robert Sobierański

Robert Sobierański

  • 192 Points 100 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
I have also experienced this at different times in my life with VMWare fusion and CentOS VM's (not just Landshark). Usually a reboot fixes the issue. Is that not the case? Has it always been this way, or did it happen some time after?
Photo of Scott MacDonald

Scott MacDonald, Staff Engineer

  • 2,522 Points 2k badge 2x thumb
Hi Robert,

It seems this can sometimes happen, and a VM restart usually sorts it out.
See this link:

http://datavirtualizer.com/cloneattack-online-and-in-person-at-eco14-doag14/

Regards,

Scott.
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
As an FYI, you can sometimes wait it out. VMWare Fusion can be very finicky. If it does eventually boot and let you in, you can try Step 11 from this thread:
https://communities.vmware.com/thread/318464
Photo of Karsten Stoehr

Karsten Stoehr, Employee

  • 870 Points 500 badge 2x thumb
Even after several reboots of the VM it still kept freezing at boot. Here's what I did to get them boot up to the login prompt:
- When powering on the VM press any button to get into the grub menu
- Press 'e' to edit the menu
- Select the second line starting with 'kernel' and press 'e' to edit this line
- At the end of the line after the 'quiet' add the parameter 'vga=normal'. [You can also use any other valid value for vga, e.g. 769 for 640x400 8 bit color or 791 for 1024x768 16bit color but normal is ok for a server install].
- Press 'enter' to save the changes
- Press 'b' to boot

Now the VM booted quickly up to the login prompt. And it did so after each reboot or power off/on.
Photo of Matt Watson

Matt Watson, Employee

  • 782 Points 500 badge 2x thumb
I have hit the same problem, Tried Karstens solution ( and many reboots ). What worked for me was to boot the guest os into emergency mode, remove vmware tools ( vmware-uninstall-tools.pl ), then reboot and reinstall vmwaretools. That appears to have done the trick.