Failed to discover environment variable $SYBASE

  • 0
  • 1
  • Question
  • Updated 3 weeks ago
  • Answered
I created the settings for the user delphix_os on host, but i have same problem with variable $SYBASE.  I made some setting for ssh.

1)«PermitUserEnvironment»  -«yes».

2)I create .ssh/environment file and add
SYBASE = /opt/sybase/ase157

3)restart ssh

I tried to create an environment but got an error:

Failed to discover environment variable $SYBASE on host

Make sure that environment variable is set for user
Photo of Bohdan

Bohdan

  • 344 Points 250 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Neal Stack

Neal Stack, Employee

  • 3,422 Points 3k badge 2x thumb
Hello,

I'm not sure what operating system and its version you are using?

It sounds like you have set the options correctly but can you show us the results of the following command?
cat .ssh/environment

And then the way you can test whether or not the environment variable is set for non-interactive logins is by executing the following command:
ssh delphix_user@ase_hostname env | grep SYBASE


Photo of Bohdan

Bohdan

  • 344 Points 250 badge 2x thumb
I solved my problem.

I have  gap in SYBASE = /opt/sybase/ase157. Correct is SYBASE=/opt/sybase/ase157.

Thanks.
(Edited)
Photo of MichaelT

MichaelT, Official Rep

  • 2,026 Points 2k badge 2x thumb
Photo of Bohdan

Bohdan

  • 344 Points 250 badge 2x thumb
Hi, i solved it. I chose New Full Backup.

Thanks for answer.