How to disable LSO on DE Engine

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Transmit Throughput is very low like 2.1Gbps for 10Gbps link. I heard if we disable LSO on engine then it will make a difference on the result.
Photo of Mohammad Farooq

Mohammad Farooq

  • 70 Points

Posted 2 years ago

  • 0
  • 1
Photo of Vivek Verma

Vivek Verma, Employee

  • 70 Points
Hi Mohammed,

LSO was designed for throughput improvement so disabling it is not recommended, unless we have determined a pathology requiring a disablement. There are some articles on the site which show this phenomenon in combination with peer LRO causing degradation in throughput (, hence, we need to determine that this is required and even then this is not the final solution.

In your case, you need to get in touch with support to determine root cause of low throughput. Also, if needed, to actually disable it on the engine you will need delphix support. 
Photo of Phil Hodkinson

Phil Hodkinson

  • 60 Points
hi Mohammed,
we saw a throughput issue on DE-> Target VM communication on the same ESX host, similar to the one described in the article Vivek pointed to. For us a solution was ring buffer tuning (increasing) in the target VM which avoided packet loss that was killing throughput. On Linux we did ethtool -G eth0 rx 4096 on the target (increased from 256).