Landshark2.0 Demo - NFS mount broken after vFiles refresh

  • 0
  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Hi,

I'm trying to test "After Refresh Run Shel Command script" in Landshark2.0 Demo environment. I'm provisioning vFiles dSource. Unfortunately it seems there is a problem with refreshing provisioned vFiles. After refreshing I get following error:

 

mount -l shows


192.168.1.53:/domain0/group-35/appdata_container-24/appdata_timeflow-30/datafile
on /data/u01/delphix2data/myapp1_6 type nfs (rw,hard,rsize=1048576,wsize=1048576,vers=3,nointr,timeo=600,tcp,actimeo=600,port=2049,addr=192.168.1.53)
I tried to unmount it and mount it again, but I get

mount.nfs: access denied by server while mounting 192.168.1.53:/domain0/group-35/appdata_container-24/appdata_timeflow-30/datafile
I think this is a known bug mentioned here http://docs.delphix.com/display/DOCS41/Release+4.1+-+4.1.x.x+Known+Issues+and+Changes in



My Delphix engine is 4.1.3.0



Is there any workaround to this problem?

Regards,
Piotr
Photo of Piotr Goliasz

Piotr Goliasz

  • 980 Points 500 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Official Response
Ahhh, and now that I cleared the junk out of my eyes, I better understand your issue. The reason why this can occur in your instance is either because a process was still running when you executed the refresh or perhaps you had an SSH session open and were sitting in the vFiles directory some where. 

try this command to see what the culprit is:
fuser /data/u01/delphix2data/myapp1_6

That should give you a process number that you can look at. If it says bash or sh, that usually means that a console session is sitting somewhere in that mount point. (Can't unmount file systems that are in use). 
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,420 Points 10k badge 2x thumb
Official Response
Glad it's working out for you! To help clarify for anyone who stumbles across this thread, Delphix provisions your files and databases to the Linux systems via NFS. So, if you remove the nfs mount while files are in use (not stopping a process running from those files or sitting in a child directory of your mount point) via a refresh, delete, or reboot of the Delphix engine, you will will end up with stale NFS handles. The easiest way to clean this up is to reboot the offending VM. But, you can also try and "suss it out."

fuser /foo/bar/mount

should return any processes using that mount point. You can then kill them.

sudo umount -f /foo/bar/mount

For the most part, that should resolve the issues. But, if that fails, reboot. :)

HTH
(Edited)