New Delphix Engine on AWS - unable to add environments (err "exception.environment.hosts.not_available")

  • 0
  • 1
  • Problem
  • Updated 6 months ago
  • Solved
We have created a new Delphix Engine on AWS. 
When we try to add an environment from the console the following actions are reported:

Create and discover environment "10.10.2.110".                           [fail warning]

Add environment user "ec2-user".                                                  [tick]

Create environment "10.10.2.110".                                                 [tick]
      Validate and create host "10.10.2.110".                                    [tick]
      Add host "10.10.2.110".                                                             [tick]

Discover information and objects for environment "10.10.2.110".   [info]
     No hosts are available for environment "10.10.2.110".
     Check the connectivity of the environment's host(s) and try discovery again.

Delete environment "10.10.2.110".                                                  [tick]
      Delete host "10.10.2.110".                                                         [tick]
      Delete all environment users for environmen...                         [tick]


The error code recorded is:
                     "exception.environment.hosts.not_available"
The suggested action is:
                     "Check the connectivity of the environment's host(s) and try discovery again."

However, connectivity appears to be fine and we can see the connection taking place at the target, where directories and files are added in the delphix directory specified. The files get tidied up automatically as the "add environment" request fails.

All the same, the environment does not appear to be added from the console.

Does anyone have any ideas what might be happening here?
Photo of Christopher Glynn

Christopher Glynn

  • 220 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Christopher Glynn

Christopher Glynn

  • 220 Points 100 badge 2x thumb
Problem was that we had not installed the 32bit glibc into the environment host.
Photo of Jaclyn Schoof

Jaclyn Schoof, Community Manager

  • 5,092 Points 5k badge 2x thumb
Hi Christopher,
I'm glad that you were able to self-solve this issue. Just for reference, our Environment Requirements documentation is here. I also want to mention that with the release of 5.2 (our most current release) we no longer require Environments to have a 32 bit glibc library (https://docs.delphix.com/docs/release-information/what-s-new-for-5-2/summary-of-5-2-features). 

- Jaclyn