NFS error while provisioning a VDB

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Getting the below error messERROR : User "delphix_os" can not mount file systems on the host

ERROR : User "delphix_os" can not mount file systems on the host

ERROR : Details : Trying "mount" using dlpx_mount - mount.nfs: requested NFS version or transport protocol is not supported;

ERROR : Could not verify umount privilege for user "delphix_os"

Linux NFS services are up and running fine.

Any ideas or thoughts?
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
This issue is usually caused by nfs v3 trying to do a reverse lookup. I typically see this in Landshark environments on Laptops where the laptops switch connectivity from one network to another, and then DNS caches get messed up.

As an attempt to resolve, empty out the /etc/resolv.conf on the LINUXTARGET and remove the DNS server in the Delphix Engine. Reboot the LINUXTARGET and Delphix Engine, then attempt again. 
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb
Hi,

I cleared out the  /etc/resolv.conf on the linux target and removed the DNS from the Engine, but the error still persists. My Linux source and targets are all VmWare VM's. I tried to do the mount commands manually and i get the below message

[root@DelphixTarget ~]# mount -v -t nfs -o nosuid,tcp,vers=3 DelphixEngine:/public /mnt/provision
mount.nfs: timeout set for Wed Jul 15 15:01:15 2015
mount.nfs: trying text-based options 'tcp,vers=3,addr=DelphixEngine'
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: portmap query failed: RPC: Program not registered
mount.nfs: requested NFS version or transport protocol is not supported

I have restarted the nfs client service also.

[root@DelphixTarget1 ~]# showmount -e Delphix4230HWv8
clnt_create: RPC: Program not registered

[root@DelphixTarget1 ~]# rpcinfo -p Delphix4230HWv8
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100155    1   tcp  37493
    100024    1   udp  46055  status
    100024    1   tcp  45894  status
    100133    1   udp  46055
    100133    1   tcp  45894
(Edited)
Photo of Michael Brown

Michael Brown

  • 1,540 Points 1k badge 2x thumb
Charles,

The rpcinfo output indicates that the nlockmgr and nfs/server services are not running on the Delphix Engine. Did you reboot your Delphix Engine? If not, please do, and observe the console during boot. Once the Delphix services display green, rerun the rpcinfo command. You should see the missing NFS services.

Thanks,

Michael
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb
Michael,

I have done many restarts of the Delphix Engine. I have also done a factory reset twice, but i do not see the NFS services getting started after the reboot. The Delphix services show up a green with the Management Service and Boot service both online, but the nfs services are still not getting started up.

Thanks
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb
Hi,

This issue has been resolved with the delphix engineer manually starting up the NFS services on the Delphix Engine. Thank you.
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb
Hi,

I was informed that the above issue has been fixed in the current release 4.2.4.

I did a restart of my virtual machine and I have hit the same issue again. 
Is there an interim patch that can be applied to the current version that i am running - 4.2.3.0 so that i don't face the same issue again.

Thanks

Regards,
Charles Theophilus
Photo of Charles Theophilus

Charles Theophilus

  • 524 Points 500 badge 2x thumb
Upgraded to version 4.2.4.0 from 4.2.3.0. through a upgrade patch. After reboots of the VM, the NFS services on the Delphix Engine are up and running. I am able to provision the VDB's as well.