• 0
  • 1
  • Question
  • Updated 5 years ago
When creating VDB, got an ORA-00845 error.
ORA-00845 : Memory_target not supported on these system.
Workaround was removing this parameter during VDB creation.
Whats's cause of this error? 
Photo of HJ


  • 540 Points 500 badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of john clark

john clark

  • 170 Points 100 badge 2x thumb
I had a similar problem but changed the value (downwards) in the "advanced" section when provisioning the VDB (Centos 6.5 OS).  I suppose that I could have made the change in the OS bur I was just testing functionality. Just FYI, I did not have this problem with Fedora.
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,884 Points 10k badge 2x thumb
the cause of the error is that there is not enough free memory on the target to support the setting on the database (which it got from the source). This can happen for a number of reasons, like running multiple vdb's on the same host. The way to get around this is as John points out. But you would have to think this is a common problem. Production database may have a setting of 64GB, but yoyr dev machine only has 8GB. In that advanced section delete (or change) the parameter and then save it as a template (perhaps named "dev template") along with any other parameters you want to change like processes. Then the next time you provision a vdb, you can just choose that template and apply the settings to your vdb. Hope this helps.