ORA-27101: shared memory realm does not exist

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered
Hello,


I just installed a few week ago oracle 12.1.0.1.0 on AIX 7.1 (2 instances, dbtest and delphix), It was working without issues. But now I'm getting the below error:
 

$ sqlplus / @testdb as sysdba

SQL*Plus: Release 12.1.0.1.0 Production on Thu Sep 4 10:14:06 2014

Copyright (c) 1982, 2013, Oracle.  All rights reserved.

ERROR:

ORA-01034: ORACLE not available

ORA-27101: shared memory realm does not exist

IBM AIX RISC System/6000 Error: 2: No such file or directory

Process ID: 0

Session ID: 0 Serial number: 0


Enviroment variables:
 

$ .oraenv

-bash: .oraenv: command not found

$ . oraenv

ORACLE_SID = [testdb] ?

The Oracle base remains unchanged with value /u01/app/oracle

$ env | grep ORACLE

ORACLE_SID=testdb

ORACLE_BASE=/u01/app/oracle

ORACLE_HOME=/u01/app/oracle/product/12.1.0/dbhome_1
 

And

$ . oraenv

ORACLE_SID = [testdb] ? delphix

The Oracle Apps base remains unchanged with value /u01/app/oracle

$ env | grep ORACLE

ORACLE_SID=delphix

ORACLE_BASE=/u01/app/oracle

ORACLE_HOME=/u01/app/oracle/product/12.1.0/dbhome_1

I also checked smon and pmon  aren't running. But I'm unable to start the database due to sqlplus issue. I  tried set to start on boot  /etc/oratab and it's not working after reboot.


$ ps -ef | grep pmon

$ ps -ef | grep smon

Thanks in advance
Photo of sarahjohn

sarahjohn

  • 122 Points 100 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Matt Griffith

Matt Griffith

  • 614 Points 500 badge 2x thumb
Hi,

This looks like it is not an issue with Delphix but with your environment. Your sqlplus command is using sqlnet to connect so it may be a problem with your tnsnames config.

Once you’ve set your environment correctly using . oraenv don’t put the @testdb in the command, so just,

sqlplus / as sysdba

(Assuming you’re connecting on the box the instance is running)