Permission error during Oracle Virtual to Physical

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Hello,

During the V2P of an Oracle Virtual DB I received from the delphix admin console
ORA-01078: failure in processing system parameters
ORA-27040: file create error, unable to create file
Linux-x86_64 Error: 13: Permission denied

I tried to reply the command create spfile='/u01/app/oracle/oradata/myDB/data/spfile.ora' from pfile= ...;

and I received the same error.

I found out that the directory /u01/app/oracle/oradata/myDB/data/ had the delphix_os owner, the oinstall group, but the permission was 5 on the group so oracle user cannot write the file.

What did I miss?

A possible workaround is to assign the oracle user to the environment, but I want to know what is the problem.

Thank you.

Gianpiero
Photo of Gianpiero Piccolo

Gianpiero Piccolo

  • 2,336 Points 2k badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Official Response
Hey Gianpiero, you are 100% correct. In the current version of Landshark 2.X, there are some permissions inconsistencies that slipped past me. I have slated to fix them in the next release. So, for now, you can just manually change the group permissions and proceed. In my Landshark environments, I just
chmod -R g+rwx /u01/app/ora* /u02/app/ora* 

You obviously can get more fine grained than that, if you so chose.