Provison and masking is not working properly through delphix engine

  • 0
  • 1
  • Problem
  • Updated 6 months ago
  • In Progress

We are unable to do the provision and the masking together. 
If we are doing the provision while adding the masking job in the delphix engine we are unable to see the data VDB. 
It is really helpful if you can help in this ASAP

Thanks in advance
Photo of Swathy Sukumar

Swathy Sukumar

  • 886 Points 500 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Gary Hallam

Gary Hallam, Official Rep

  • 2,008 Points 2k badge 2x thumb
Hi Swathy,  Your description is a little vague.  When you say you cannot see the data VDB do you mean that the provision job finishes but the VDB cannot be accessed or is the column data missing?  Does the provisioning job complete?  Does the masking job fail?  If the maskig job fails then the VDB will not be provisioned for security reasons.
Regards,
Gary
Photo of Gary Hallam

Gary Hallam, Official Rep

  • 2,008 Points 2k badge 2x thumb
Can you run the masking job manually on a copy of the VDB? - see whether it completes successfully and see how long it takes.
Photo of Swathy Sukumar

Swathy Sukumar

  • 886 Points 500 badge 2x thumb
Hi Gray,

Thanks for your response.
Yes masking job is completed through delphix masking suite.But when we use the same job while provision the VDB we are unable to see the data in the VDB.
There is no error message.

Thanks in advance
Photo of Gary Hallam

Gary Hallam, Official Rep

  • 2,008 Points 2k badge 2x thumb
Hi Swathy,
Well I just tested on my viersion 5.2.3.1 and all seems fine.  So I would check that the masking job has run and completed successfully - you can see that in the UI clicking the Admin Tab then logs and scrolling down.  You can also look in the Actions bar in the Delphix Admin console and see that the masking actually ran.  You can also look in the logs on the Delphix Engine - System|Jobs.
If it's not obvious then please raise a support case and provide a support bundle.
Regards,
Gary
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,782 Points 4k badge 2x thumb

Hi Swathy,

Please can you confirm the following:

- Job is configured as multitenant on masking engine
- You have associated the masking job with dsource
- At VDB provision time you choose the masking job to be applied on the vdb


Regards,

Mouhssine