Segment mapping Special Character Handling

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • In Progress
  • (Edited)
Hi there, I understand that the input character set for Segment mapping Algorithm is US-ASCII 7 bit Alphabetic characters (letters and numbers). Which includes !@%^ etc. Why does the masking fail when special characters are encountered? Also I am trying to ignore the 1⁄2 in one of the columns, which is not from the above character set, is there any way of doing this? I am using ALPA-NUM segment mapping.
Photo of EnterpriseMan

EnterpriseMan

  • 630 Points 500 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of MichaelT

MichaelT, Official Rep

  • 1,992 Points 1k badge 2x thumb
Hi madhu,
I think this answers both of your questions, please let me know. 
I asked our team here and one of our engineers stated:
SM covers only a-z, A-Z and 0-9
Any characters other than that BREAK the logic and need to be added to the ignore characters list - including @, blank,-,_,....
So, that would definitely be the issue in this scenario, correct? 

Thanks,
Michael
Photo of EnterpriseMan

EnterpriseMan

  • 630 Points 500 badge 2x thumb
Thanks Michael, I have worked around with idea so far. However I need to ignore 1/2 (Symbol) which is in our oracle data, which the ignore list is not ignoring even after adding to it. I understand it only takes ascii 7, and this symbol is not that. Is there a workaround to ignore such special characters?
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 5,846 Points 5k badge 2x thumb
Hi madhu,

One option I think of is setting this sign as a segment it self and not define any masking value for it or play with pre and post scripts on masking.

Regards,

Mouhssine
Photo of EnterpriseMan

EnterpriseMan

  • 630 Points 500 badge 2x thumb
Hi, thanks for the response, this character is not bound to exist in the same position, it varies. I think post steps will be the only option..