Start and Stop VDB through API

  • 0
  • 1
  • Problem
  • Updated 6 months ago
  • In Progress

Hi All,

I tried to run the API call under to start & shut the VDb

https://docs.delphix.com/pages/viewpage.action?pageId=60492371

Note: have changed the URL for the engine as per my project

<!DOCTYPE html><html><head><title>Apache Tomcat/8.0.36 - Error report</title><style type="text/css">H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}.line {height: 1px; background-color: #525D76; border: none;}</style> </head><body><h1>HTTP Status 403 - Use /resources/json/delphix/login to log in first</h1><div class="line"></div><p><b>type</b> Status report</p><p><b>message</b> <u>Use /resources/json/delphix/login to log in first</u></p><p><b>description</b> <u>Access to the specified resource has been forbidden.


I tried doing ssh to the url with the credentials I used in the script, it connected fine.


Photo of Chandrasekhar Pantla

Chandrasekhar Pantla

  • 242 Points 100 badge 2x thumb
  • eager to know the solution

Posted 6 months ago

  • 0
  • 1
Photo of Neal Stack

Neal Stack, Official Rep

  • 2,512 Points 2k badge 2x thumb
Hello,

Did you update the version of the API to match the version in use of your Delphix Engine?

ssh delphix_admin@nstack519.dcenter.delphix.com
nstack519.dcenter> version
1.8.2

Did you change the username and password? The error shows that you failed to login:
{
    "type": "LoginRequest",
    "username": "${DELPHIX_ADMIN}",
    "password": "${DELPHIX_PASS}"
}
Version and the passwords are as required. Still got the same error
Photo of Neal Stack

Neal Stack, Official Rep

  • 2,512 Points 2k badge 2x thumb
Hello,

I'd suggest opening a technical support case and upload a support bundle along with the full context of your code. There are debug logs in the support bundle that would help us understand:
a) The authentication method your Delphix engine is configured to use (LDAP vs Native)
b) Why the authentication is failing.

Thanks,
  Neal