timestamp error on dx_rewind_db script

  • 0
  • 1
  • Problem
  • Updated 7 months ago
  • Solved
I am getting this error when trying to rewind to a specific snap by timestamp. 
'Timestamp format doesn't match any known format
Error with setting point in time for rewind'.

this is the command I entered: 

c:\Delphix\dxtoolkit2>dx_rewind_db -d delphixt05 -group VDB_Team -name CABS -timestamp '2018-10-16 03:30'

Here is the list that shows it exists:

Engine                         Group                Database                       Snapshot name                  Start time                     End time

------------------------------ -------------------- ------------------------------ ------------------------------ ------------------------------ ------------------------------

delphixt05                     VDB_Team             CABS                           @2018-10-16T03:30:28.110       2018-10-16 03:30:28 EDT        2018-10-16 03:30:28 EDT
Photo of joe sernicola

joe sernicola

  • 230 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Matt Griffith

Matt Griffith

  • 930 Points 500 badge 2x thumb
Hi Joe,

You're missing the seconds (YYYY-MM-DD HH24:MI:SS) from the timestamp.  Try '2018-10-16 03:30:28'

Photo of joe sernicola

joe sernicola

  • 230 Points 100 badge 2x thumb
Hi Matt,
The syntax doesn't require the seconds but I had tried that already and I get the same error. 
Photo of fMarcin Przepiorowski

fMarcin Przepiorowski, Employee

  • 1,230 Points 1k badge 2x thumb
Official Response

I did some research and it's looks to be a Windows issue.
If you are using a single quote and an argument has a space character - only first part of argument is used and dxtoolkit see your timestamp as 2018-10-16 and it's not recognize it.

Please using double quote for time stamp like this 

dx_rewind_db -d delphixt05 -group VDB_Team -name CABS -timestamp "2018-10-16 03:30"

I will add a better error message into dxtoolkit so this kind of issues should be easier to find in the future.


be careful with copy paste - double quote can be replaced by MS Offices tools.

Photo of joe sernicola

joe sernicola

  • 230 Points 100 badge 2x thumb
Apparently, in a Windows environment, single quotes are not recognized. We used  double quotes around the timestamp and it worked.   "2018-10-16 03:30"