Unable to register Delphix Demo Version.

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Unable to register Delphix Demo Version from DelphixExpress GUI. Its showing proxy error stating its not able to connect with  "https://register.delphix.com". We don't have any proxy configured in Our Network and the VM where engine is configured is provided with internet access.
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
I had restarted the Delphix Engine and its showing Delphix Management System is showing as Offilne and Delphix Boot System as Online. Will that be any cause for this failure.
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb
Hi Hemachandra,

You have to stand until every resources chanes the status to online and get a green screen.

You can mark the appliance as registred and register manually your engine connecting to the "https://register.delphix.com" url and pasting the registration code from the admin console.

Regards,

Mouhssine
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Hi Mouhssine,

I am trying to configure the Trial Version. I am bit confused about the above details.

Where can I mark the appliance as registered. In the Initial Configuration screen it is not allowing me to mark the Appliance as registered. below is the Screen shot.

Is there any option to Mark it as registered using CLI?

And what is the admin console. How can see the delphix admin console. Without registering the appliance it is not allowing to move further.

Please help me in this.

Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb
Hi Hemachandra,

Sorry for the confusion.

To register your Express engine con you connect please to this url "https://accounts.delphix.com/", and choose the option "Delphix Engine registration" and connect via your community account to register your engine.

Regards,

Mouhssine
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Hi Mouhssine,

I had created the account and logged in to the site  "https://accounts.delphix.com/". But there is no option for "Delphix Engine registration". 

Below is the screen shot with options what I got.

Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb
Hemachandra,

I'm afread that can't help with this issue and sorry for that, the only option you have is to request help from a delphix employee.

But, just checked this link "https://docs.delphix.com/display/DOCS..." and found indeed that there is limitation on the express version.

Delphix Express is a free version of the Delphix platform, but does have a few limitations in place. In particular, please make note of the following:
Registration: Registration is required during setup. You will not be able to proceed past setup unless you register. New accounts can be created at accounts.delphix.com.

Or try to reload the ova again but ensure that you configure your vm to use an ip address (ex : NAT) that allows to access internet.

Regards,

Mouhssine
Photo of Mouhssine SAIDI

Mouhssine SAIDI

  • 4,682 Points 4k badge 2x thumb
Hi,

Please ensure that you followed the documentation especially "Vm network settings".

https://docs.delphix.com/display/DOCS...

Sorry Again,

Mouhssine
Photo of Adam Bowen

Adam Bowen, Official Rep

  • 17,418 Points 10k badge 2x thumb
Hello. For the free version of Delphix, your Delphix Engine has to communicate back to Delphix. There is no option to bypass this. Though you might not need to configure a special webproxy for internet access, it is possible your IT environment does not allow all user-agents (i.e wget) to do web queries by default. Ask your IT team to see if they see a user-agent being blocked trying to access the internet from your VM. I have seen this in quite a few corporate settings. 
Photo of Hemachandra

Hemachandra

  • 310 Points 250 badge 2x thumb
Hi Adam,

Sorry I was ill and not able to reply you back. 

I had followed the process of registering the Appliance with the CLI and my community credentials.

I had taken the registration code from the appliance and pasted in the https://register.delphix.com site and I got the reply as shown in below screen shot.

I even got the email confirmation as below



I had restarted the Engine after this process. After all the services are Online I tried to open the Delphix Engine ServerSetup. But still it is redirecting me to the Initial Configuration Page asking me to configure.

I had entered all the details but still it got stuck at the Registration Page with the error posted previously.

Will the above process work for Trail? If not is there any other way that I can register my appliance.