Delphix Products

  • 1.  API version

    Posted 05-08-2020 04:20:00 AM
    ​Hello Everyone

    I could see why the API version is showing like "base url: /masking/api , api version: 5.0.0 " at bottom of the API page even the masking engine runs on latest version 5.3.7 or higher?

    ------------------------------
    Karteek Muthyala
    Information Security Engineer
    Wells Fargo
    ------------------------------


  • 2.  RE: API version

    Posted 05-08-2020 04:38:00 AM

    Hello Karteek,

    Could you clarify what you mean, are you expecting the API version to match the Delphix Engine Release?

    Thanks,
    Luke. 



    ------------------------------
    Luke Moss
    Delphix Support
    Delphix
    ------------------------------



  • 3.  RE: API version

    Posted 05-08-2020 10:36:00 AM
    Yes Luke
    Why am not seeing the current masking engine version under the API version? they should not be same or what?​

    ------------------------------
    Karteek Muthyala
    Information Security Engineer
    Wells Fargo
    ------------------------------



  • 4.  RE: API version

    Posted 05-08-2020 10:41:00 AM
    Hi Karteek,

    No, they are different entities.
    If you refer to the documents posted by Neal this should explain more about API and API versioning.

    Thanks,
    Luke.

    ------------------------------
    Luke Moss
    Delphix Support
    Delphix
    ------------------------------



  • 5.  RE: API version
    Best Answer

    Posted 05-08-2020 08:13:00 AM
    Hello,

    This link discusses the Masking Engine's API versioning:
      https://maskingdocs.delphix.com/Delphix_Masking_APIs/Masking_Client/Backwards_Compatibility_API_Usage/#api-versioning-context

    This link discusses the Virtualization Engine's API versioning:
      https://docs.delphix.com/docs/developer-s-guide/web-services-api-guide/api-version-information

    ------------------------------
    Neal Stack
    Senior Principal Technical Support Engineer
    Delphix
    ------------------------------