Delphix Products

Expand all | Collapse all

Delphix engine asks for response when trying to login

Jump to Best Answer
  • 1.  Delphix engine asks for response when trying to login

    Posted 11-01-2015 02:02:00 PM
    Hi, 

    i am trying to set up a landshark environment, but got problem with the Delphix engine.
    If i try to login, it asks for a "response".

    I have registred the delphix instance but still get:

    Engine|Challenge: 564d1b03-0689-2985-da94-2e82c4c7531e|26809770

    Response: 


    An empty response was entered. Please try again with a valid response. If the

    Delphix Engine is not registered, register it at


        https://register.delphix.com/


    using the registration code below:


    OuQimfvETRG25ZbqoGmX0EVyiCc0GUh3XFekCVsY3p1/IuuD93thtmoMUm7CtO+CYebl5QhpBjW9g3FQ

    NKlFHyEEe2yObURcUdc8U8jQxRmiV7flc8TDrPcw/QQZTBD3QMH7//2fVQMEb9/pJ7VL96SYwihgAnao

    VhMBdNDhPvjA7u2/Foe8OT4eRpLussbzWFgtTbWKu1uxk0WtuCjiCalX+1NKml0mzlkr5Uisx3kW3HrB

    2CiAAZr+AtTBg7mMRGk/Kcjmb+gOEupZr6YGNdR/+cj4ir7SrGAESgQVQeriLZYIG3r8DVefLG6hRw6o

    F/dUlZRZeNrAXFEja87/3Ta9dLliu8GXdl9Zfj7Ph+h3VlXeJaK/xZNlggFo6zw9MnDyaCGUgxDaLLuM

    wbCcEpm903UprHDjyNPP10PbEFsbVIswVVpJnHSByQiGekctfjh4zxXdTxB4UKm/IhKfwO0MOxiUqVAx

    uVy9bARVraRqgMQF97qR/I99+p86cMObpgWqu1bzQihcLuDpHYrBCLv/z9pf/auxaPjlYw0iRUhgHYS6

    3J9gNPjDp25Aazca06eb6ect7IWJCzzbY1+N7bNTrKg7IrOLO54T4d8ns7W+IbBEoBf+Ri1W9Dr5QGWG

    mm/CVTsxaCzWyk6CwlxmBv/BcylHppNUzOufsDvffWY=|564d1b03-0689-2985-da94-2e82c4c7531

    e


    Engine|Challenge: 564d1b03-0689-2985-da94-2e82c4c7531e|73706525

    Response: 


    What is the response it asks for? Should i have got it during registration?


    I also got this from the landshark_setup.log

    NFO:2015-11-01 09:53:28:Scanning for the Landshark Delphix Engine

    DEBUG:2015-11-01 09:53:30:10.0.2.131 appears to be a Delphix Engine

    DEBUG:2015-11-01 09:53:30:Establishing a server session

    DEBUG:2015-11-01 09:53:30:Fetching Delphix Engine Info

    DEBUG:2015-11-01 09:53:30:10.0.2.131: POST(/resources/json/delphix/session, {"locale": "en_US", "client": "delphixpy", "type": "APISession", "version": {"micro": 0, "major": 1, "type": "APIVersion", "minor": 4}}, {'Content-Type': 'application/json'})

    DEBUG:2015-11-01 09:53:30:10.0.2.131: POST(/resources/json/delphix/login, {"username": "delphix_admin", "password": "landshark", "type": "LoginRequest", "target": "DOMAIN"}, {'Cookie': 'JSESSIONID=4C988F43D6533326B6719406ADE79522; Path=/resources/; HttpOnly', 'Content-Type': 'application/json'})

    DEBUG:2015-11-01 09:53:30:10.0.2.131: GET(/resources/json/delphix/system, {'Cookie': 'JSESSIONID=4C988F43D6533326B6719406ADE79522; Path=/resources/; HttpOnly', 'Content-Type': 'application/json'})

    DEBUG:2015-11-01 09:53:30:10.0.2.131 is a Delphix Engine, but it did not return the address

    designated as the Landshark Engine ("Delphix4320HWv8").

    If this is the intended Landshark Delphix Engine, please correct your setup and try again.

    INFO:2015-11-01 09:53:30:Did not find a suitable Landshark Delphix Engine.

    Repeating discovery loop in 60 seconds.

    Ensure your Delphix Engine is powered on.

    Any suggestion what is wrong?

    I have one working installation on my my IMac, now i tries to install it on my MacBook Pro. Both running fushion. 8 on IMax and 6 on MaxBook.

    Best regards

    Per


    #DemoEnvironment


  • 2.  RE: Delphix engine asks for response when trying to login
    Best Answer

    Posted 11-01-2015 02:57:00 PM
    Hi Per,

    Try to log in using following syntax:

    ssh sysadmin@SYSTEM@delphix_engine_ip

    or

    ssh delphix_admin@DOMAIN@delphix_engine_ip

    This should work for you.

    See docs here: https://docs.delphix.com/display/DOCS43/Connecting+to+the+CLI">https://docs.delphix.com/display/DOCS43/Connecting+to+the+CLI">https://docs.delphix.com/display/DOCS43/Connecting+to+the+CLI

    Regards,
    Piotr


  • 3.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 04:40:00 PM
    Thanks! 
    That works.

    I still got the problem with the landshark setup shown in the log file in the previous post.
    Any suggestion on how to fixit?


    I have restarted the VMs but still the same..

    Best regards, 
    Per


  • 4.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 04:54:00 PM
    Thanks Piotr for helping! Per, the second part is because the landshark setup is expecting your Engine name to be "DelphixExpress" but is actually named  (designated as the Landshark Engine ("Delphix4320HWv8"). You can either change the Engine name  or change the value the landshark setup is expecting.

    To change the engine name follow step 6: 
    https://docs.delphix.com/display/LS22/Quick+Start+Guide+for+the+Delphix+Landshark+Environment#QuickS...

    To change the parameters the the setup is expecting: 
    1. https://docs.delphix.com/display/LS22/Viewing+and+editing+the+landshark_properties.xml
    2. https://docs.delphix.com/display/LS22/The+ENGINE+Section#TheENGINESection-engine_hostname


  • 5.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 07:13:00 PM
    Thanks, 

    i change the parameters.

    I have problem logging in as sysadmin@SYSTEM on the Delphix engine VM.
    What could have happen? I Can log in as delphix_admin@DOMAIN but then i can't run the step 6 in the manual for changing the engines namn.

    Best regards, 
    Per


  • 6.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 07:30:00 PM
    When you ssh sysadmin@SYSADMIN@delphix_ip does it prompt you for a password, or for a challenge response?

    If it prompts you for a challenge response, it is not recognizing your login.


  • 7.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 07:31:00 PM
    What about attempting to login at the VM console, instead of via SSH?


  • 8.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 07:39:00 PM
    i have also tried the VM console, but gets the same. 
    In the instruction it says sysadmin@SYSTEM?

    If i try to login with sysadmin on the VM console i get incorrect password

    have tried both sysadmin@SYSTEM and sysadmin@SYSADMIN password sysadmin

    //Per


  • 9.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 07:41:00 PM
    Yes, sorry. sysadmin@SYSTEM. Did you change the sysadmin password when you went through the initial setup wizard (when it asked you for a email and new password for the sysadmin user)?


  • 10.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 08:34:00 PM
    After restarting the VMs and so i got the setup a bit further.

    Now there is some problem when creating source db

    Any suggestions?

    // Per
       landshark.oracle_xe_source.container_ref = database.link(server, landshark.oracle_xe_source.params)

      File "build/bdist.linux-x86_64/egg/delphixpy/web/database/__init__.py", line 389, in link

      File "build/bdist.linux-x86_64/egg/delphixpy/response_validator.py", line 39, in validate

    delphixpy.exceptions.RequestError: APIError(action=u'Make sure that the username provided has access rights to system views, and that the host server can be reached.', command_output=None, details=u'Cannot connect to database due to: Exception occurred while getting connection: oracle.ucp.UniversalConnectionPoolException: Cannot get Connection from Datasource: java.sql.SQLException: Listener refused the connection with the following error:\nORA-12505, TNS:listener does not currently know of SID given in connect descriptor\n ', id=u'exception.oracle.dbc.database.failed.connection', type=u'APIError')





  • 11.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 08:40:00 PM
    got this when running landshark_setup.py logged in as delphi on the target VM


  • 12.  RE: Delphix engine asks for response when trying to login

    Posted 11-01-2015 09:48:00 PM
    what is the result of the following command on the source as delphix: /home/delphix/oracleTest


  • 13.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 09:08:00 AM
    looked into oracleTest, but i don't got the path that was set in oracle home
    #!/bin/bash

    #2.0.0

    #For the Source

    unset DISPLAY

    export TMP=/u02/tmp

    export TMPDIR=/u02/tmp

    export ORACLE_HOME=/u01/app/oracle/product/11.2.0/dbhome_1

    export PATH=$ORACLE_HOME/bin:$PATH

    export ORACLE_SID=orcl


    lsnrctl status LISTENER

    sqlplus -L delphixdb/delphixdb <<EOF


    Only got xe under the 11.2.0

    [delphix@linuxsource 11.2.0]$ pwd

    /u01/app/oracle/product/11.2.0

    [delphix@linuxsource 11.2.0]$ ls

    xe

    Best regards
    Per






  • 14.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 09:50:00 AM
    ahhh yes, because i built that for 11g. Run this:

    unset DISPLAY

    export TMP=/u02/tmp

    export TMPDIR=/u02/tmp

    export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe

    export PATH=$ORACLE_HOME/bin:$PATH

    export ORACLE_SID=XEXE


    lsnrctl status LISTENER

    sqlplus -L delphixdb/delphixdb <<EOF

    EOF



  • 15.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 11:22:00 AM
    here's what it looks like on my linuxsource:
    $ ssh delphix@192.168.111.162delphix@192.168.111.162's password:
    Last login: Thu Sep 24 14:20:15 2015 from 192.168.111.1
    [delphix@linuxsource ~]$ unset DISPLAY
    [delphix@linuxsource ~]$ export TMP=/u02/tmp
    [delphix@linuxsource ~]$ export TMPDIR=/u02/tmp
    [delphix@linuxsource ~]$ export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe
    [delphix@linuxsource ~]$ export PATH=$ORACLE_HOME/bin:$PATH
    [delphix@linuxsource ~]$ export ORACLE_SID=XEXE
    [delphix@linuxsource ~]$ lsnrctl status LISTENER

    LSNRCTL for Linux: Version 11.2.0.2.0 - Production on 02-NOV-2015 07:20:30

    Copyright (c) 1991, 2011, Oracle.  All rights reserved.

    Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
    STATUS of the LISTENER
    ------------------------
    Alias                     LISTENER
    Version                   TNSLSNR for Linux: Version 11.2.0.2.0 - Production
    Start Date                25-SEP-2015 07:09:45
    Uptime                    38 days 1 hr. 10 min. 45 sec
    Trace Level               off
    Security                  ON: Local OS Authentication
    SNMP                      OFF
    Listener Log File         /u01/app/oracle/diag/tnslsnr/linuxsource/listener/alert/log.xml
    Listening Endpoints Summary...
      (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=linuxsource)(PORT=1521)))
    Services Summary...
    Service "XEXDB" has 1 instance(s).
      Instance "XEXE", status READY, has 1 handler(s) for this service...
    Service "XEXE" has 1 instance(s).
      Instance "XEXE", status READY, has 1 handler(s) for this service...
    The command completed successfully
    [delphix@linuxsource ~]$
    [delphix@linuxsource ~]$ sqlplus -L delphixdb/delphixdb <> EOF

    SQL*Plus: Release 11.2.0.2.0 Production on Mon Nov 2 07:20:35 2015

    Copyright (c) 1982, 2011, Oracle.  All rights reserved.

    ERROR:
    ORA-28002: the password will expire within 7 days



    Connected to:
    Oracle Database 11g Express Edition Release 11.2.0.2.0 - 64bit Production

    SQL> Disconnected from Oracle Database 11g Express Edition Release 11.2.0.2.0 - 64bit Production
    [delphix@linuxsource ~]$


  • 16.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 01:00:00 PM
    Hi, 

    Run this script:
    unset DISPLAY

    export TMP=/u02/tmp

    export TMPDIR=/u02/tmp

    export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe

    export PATH=$ORACLE_HOME/bin:$PATH

    export ORACLE_SID=XEXE

    lsnrctl status LISTENER

    sqlplus -L delphixdb/delphixdb <<EOF

    i got this when i ran your script:
    LSNRCTL for Linux: Version 11.2.0.2.0 - Production on 02-NOV-2015 07:57:59


    Copyright (c) 1991, 2011, Oracle.  All rights reserved.


    Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))

    STATUS of the LISTENER

    ------------------------

    Alias                     LISTENER

    Version                   TNSLSNR for Linux: Version 11.2.0.2.0 - Production

    Start Date                01-NOV-2015 15:57:00

    Uptime                    0 days 16 hr. 0 min. 59 sec

    Trace Level               off

    Security                  ON: Local OS Authentication

    SNMP                      OFF

    Listener Log File         /u01/app/oracle/diag/tnslsnr/linuxtarget/listener/alert/log.xml

    Listening Endpoints Summary...

      (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=linuxtarget)(PORT=1521)))

    The listener supports no services

    The command completed successfully

    ./oracleTest: rad 20: varning: här-dokument på rad 20 avgränsas av filslut (ville ha "EOF")


    SQL*Plus: Release 11.2.0.2.0 Production on Mon Nov 2 07:57:59 2015


    Copyright (c) 1982, 2011, Oracle.  All rights reserved.


    ERROR:

    ORA-01034: ORACLE not available

    ORA-27101: shared memory realm does not exist

    Linux-x86_64 Error: 2: No such file or directory

    Process ID: 0

    Session ID: 0 Serial number: 0



  • 17.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 01:04:00 PM
    Ok. That's interesting. So the XEXE database is truly no longer running after reboot. Reboot the linuxsource again.  Then see if the XEXE database is running. If not, can you check the database startup log?


  • 18.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 01:18:00 PM
    Still not running.

    found this in latest log:
    [delphix@linuxtarget client]$ cat clsc43.log 

    Oracle Database 11g Clusterware Release 11.2.0.2.0 - Production Copyright 1996, 2010 Oracle. All rights reserved.

    [    CLSE][4107343616]clse_get_crs_home: Error retrieving OLR configuration [0] [Error opening olr.loc file. No such file or directory]

    [delphix@linuxtarget client]$ 

    Or should i look in some other log?



  • 19.  RE: Delphix engine asks for response when trying to login

    Posted 11-02-2015 01:25:00 PM
    Let's do this. Post the output of the following commands:
    ifconfig -a
    cat /etc/hosts
    source XE.env
    lnsrctl status
    sqplus / as sysdba
    startup;