Delphix Products

Expand all | Collapse all

Is there a way to disable the "Delphix Engine nearing limit" email alert?

Jump to Best Answer
  • 1.  Is there a way to disable the "Delphix Engine nearing limit" email alert?

    Posted 09-26-2017 12:51:00 PM

    Hi,

    Is there a way to disable the email alert with subject: Delphix Engine nearing limit on number of dSources and VDBs ?

    I know the new version of Delphix has more filtering when it comes alerting, but I can't figure out how to disable this one alert through the CLI. I would like to receive other warning emails, just not this one in particular.


    Thanks,

    Meagan


    #Virtualization


  • 2.  RE: Is there a way to disable the "Delphix Engine nearing limit" email alert?
    Best Answer

    Posted 09-26-2017 01:57:00 PM
    Hi Meagan,

    You can set up a NotFilter containing an EventFilter for the event string "max_allowed_containers*" (with the asterisk) which should match everything apart from that event.

    Let me know if you need help creating that, but basically you want to create a NotFilter for the first filterSpec, and then create an EventFilter as the subFilter for that overall NotFilter (i.e. create the NotFilter first). Hope that makes sense.

    Regards,

    Scott.


  • 3.  RE: Is there a way to disable the "Delphix Engine nearing limit" email alert?

    Posted 09-26-2017 04:42:00 PM

    Hi Scott,


    Thanks for the info - Would you be able to provide an example?


    Thanks,

    Meagan



  • 4.  RE: Is there a way to disable the "Delphix Engine nearing limit" email alert?

    Posted 09-27-2017 03:08:00 PM
    Hi Meagan,

    Sorry for the delay, been a bit tied up, but here we go. I haven't had a chance to fully test this, but it should work.
    First, I'll create a new alert profile and set it for my e-mail:

    delphixsvr01> /alert/profile/create
    delphixsvr01 alert profile create *> edit actions
    delphixsvr01 alert profile create actions *> add
    delphixsvr01 alert profile create actions 0 *> set addresses=scott.macdonald@delphix.com
    delphixsvr01 alert profile create actions 0 *> back
    delphixsvr01 alert profile create actions *> back

    okay, so we have actions set (mail me), now to add the filterSpecs (a Not inversion containing an Event filter):

    delphixsvr01 alert profile create *> edit filterSpec
    delphixsvr01 alert profile create filterSpec *> set type=NotFilter 
    delphixsvr01 alert profile create filterSpec *> edit subFilter
    delphixsvr01 alert profile create filterSpec subFilter *> set type=EventFilter 
    delphixsvr01 alert profile create filterSpec subFilter *> set eventTypes=*allowed*
    delphixsvr01 alert profile create filterSpec subFilter *> back
    delphixsvr01 alert profile create filterSpec *> back
    delphixsvr01 alert profile create *> ls
    Properties
        type: AlertProfile
        actions:
            0:
                type: AlertActionEmailList (*)
                addresses: scott.macdonald@delphix.com (*)
                format: HTML (*)
        filterSpec:
            type: NotFilter (*)
            subFilter:
                type: EventFilter (*)
                eventTypes: *allowed* (*)
    delphixsvr01 alert profile create *> commit
        ALERT_PROFILE-37
    delphixsvr01 alert profile> 

    Hope that helps, let us know how you get on.

    Regards,

    Scott.





  • 5.  RE: Is there a way to disable the "Delphix Engine nearing limit" email alert?

    Posted 10-03-2017 12:29:00 PM

    Hi Scott,


    I followed your example, but I did change the actions type to AlertActionEmailUser. We're actually getting more alerts than before, in addition to still getting the "Delphix Nearing Limit" email. Would it be best for me to set up a support call to go over through WebEx?


    Thanks!

    Meagan



  • 6.  RE: Is there a way to disable the "Delphix Engine nearing limit" email alert?

    Posted 10-06-2017 08:38:00 AM
    Hi Meagan,

    Sorry for the delay, yes I think it would be worth raising a case to do this, it'll be easier to talk about.

    Thanks,

    Scott.