Library issue with dxtoolkit2 version 2.3.7 and 2.38 - Dependent module /usr/lib/libcrypto.so could not be loaded.

  • 0
  • 1
  • Problem
  • Updated 5 months ago
  • Solved
Hi, 
I am trying out automating VDB provisioining. 
I have engine version 5.1.9 and  had  Toolkit version 2.3.2 . 
I am executing the tollkit from AIX to provision an Oracle VDB on to Oracle platform. 

Command for VDB creaton was :
/oraback01/admin/delphix_scripts/DX_KIT/dxtoolkit2/dx_provision_vdb -engine app1002p \
 -sourcename WPRNSAC1 -group SAC_VDB_TRAINING -targetname V_TEST environment uora1009n \
 -dbname V_TEST -envinst /opt/oracle/product/12.1.0.2 -type oracle \
 -mntpoint /mnt/delphix -envUser svcdpx -listeners BSCLISTENER \
 -archivelog no -redoGroup 5 -redoSize 250 -autostart yes

It failed with an error:
Error: source->allowAutoVDBRestartOnHostReboot->The field "{0}" is required.

It looks like -autostart=yes s not getting translated to source.allowAutoVDBRestartOnHostReboot properly. 

So, I downloaded the version 2.3.7 and 2.3.8 of the toolkit and tried again. 
This time I am gettign an error :
0509-150   Dependent module /usr/lib/libcrypto.so could not be loaded.
        0509-022 Cannot load module /usr/lib/libcrypto.so.
        0509-026 System error: Cannot run a file that does not have a valid format.
        0509-022 Cannot load module /tmp/par-737663647078/cache-5bc4fc3becf630d1a27dbd5d2730a625d4d4f61b/8b879676.so.
        0509-150   Dependent module /tmp/par-737663647078/cache-5bc4fc3becf630d1a27dbd5d2730a625d4d4f61b/8b879676.so could not be loaded. at /loader/HASH(0x110122898)/DynaLoader.pm line 193.


I tried setting up the LD_LIBRARY_PATH to include /usr/bin and the libraries are in that location.  It didn't make any difference. 

Has anyone faces it? Any suggestions ? 
Photo of Ansamma Mathews

Ansamma Mathews

  • 292 Points 250 badge 2x thumb

Posted 5 months ago

  • 0
  • 1
Photo of fMarcin Przepiorowski

fMarcin Przepiorowski, Employee

  • 1,230 Points 1k badge 2x thumb
Official Response
Hello,

Newest version of AIX was compiled with a newest version of OpenSSL library 1.0.2n.
If this version is not available on your AIX installation, please download a file called dxtoolkit2-2.3.8.1-aix-openssl which include a openssl libraries and should work on any AIX.

https://github.com/delphix/dxtoolkit/releases/download/v2.3.8.1/dxtoolkit2-2.3.8.1-aix-openssl.tar.g...


regards,
Marcin