Major rendering bug in Google Chrome

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Hi,

In Google Chrome, this is the view I am greeted with:




As you can see in the screenshot, the page only renders in the top portion of the page. I didn't have this problem until I upgraded to Chrome 39. This is my user agent:

Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36
I am on Windows 7.

I wrote a userscript to fix the problem (it's a bit of a hack, but it works), but it would be nice to see this fixed. Here is the script:

// ==UserScript==
// @name         Delphix fix
// @namespace    http://avindra.adp.com
// @version      0.1
// @description  Fix for Delphix rendering bug
// @author       Avindra Goolcharan
// @match        http://51.16.109.229/Server.html*
// @grant        none
// ==/UserScript==
setTimeout(function() {
    $("#flashContent").removeAttr("style");
    $("embed").css("height", "101%"); 
}, 5000);
My coworker, who also has the same Chrome version, has the same issue. The only extension I have installed which affects webpages is Adblock plus and I doubt that is the cause.
Photo of Avindra Goolcharan

Avindra Goolcharan

  • 404 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Michael Brown

Michael Brown

  • 1,540 Points 1k badge 2x thumb
Official Response
Avindra,

As you deduced, this issue was introduced by changes Google made in Chrome 39, and it affects that browser on all OS platforms. We have already addressed this in code to be released in an upcoming maintenance release of Delphix Engine. We have observed that simply resizing the browser window vertically resolves the issue for the duration of that session. We appreciate you sharing your workaround with the community as well!

Thank you,

Michael
Photo of Tom Southerland

Tom Southerland

  • 230 Points 100 badge 2x thumb
Official Response
Thanks for the feedback. A quick resize of the window will force Chrome to redraw it correctly. This has been fixed as of Delphix version 4.1.4.0.