Cannot Delete dSource after deleting it from host

  • 0
  • 1
  • Problem
  • Updated 7 months ago
  • Solved
hi,

we have a dSource Test that has a couple of VDB provisioned from it. We deleted the database from the host, which caused the dSource and its VDBs to show errors such as "Cannot Monitor" and "Provision Problem". Now we cannot delete the dSource because it has dependencies (the VDBs), but the VDBs cannot be deleted from the console. When I tried it gave: ORA-01034: ORACLE not available. I tried through CLI but same result.


Any solution on removing the dSource and its VDBs from the engine console? 
Photo of Abdullah alsuwailem

Abdullah alsuwailem

  • 240 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Sean Nothdurft

Sean Nothdurft, Technical Support

  • 1,000 Points 1k badge 2x thumb
Official Response
Hi Abdullah-

In the Delphix interface, when deleting a VDB you should be presented with an option to "Force Delete". This bypasses the normal steps of disabling the database, unmounting filesystems, etc, and is used for this exact scenario.  Is this option not presented to you when attempting to delete?



The only thing that should prevent deletion from the Delphix UI is if the VDB is associated with a container in Jet Stream / Delphix Self Service, in which case the container must be deleted first.  In this instance, the delete option would be greyed out.  As you didn't express this specifically, we must ask if that is applicable here.

Also, from the CLI you can run:

DelphixEngine> /database; select <vdbname>
DelphixEngine database 'vdbname'> delete
DelphixEngine database 'vdbname' delete *> ls
Properties
    type: OracleDeleteParameters
    credential: (unset)
    force: (unset)
    username: (unset)

DelphixEngine database 'vdbname' delete *> set force=true
DelphixEngine database 'vdbname' delete *> commit

Hope this helps.